stable

rust-async-executor-1.5.0-1.el9, rust-fs-err-2.9.0-1.el9, & 6 more

FEDORA-EPEL-2023-4c09a485b8 created by salimma a year ago for Fedora EPEL 9

Updates terminal_size to 0.2 and provides a compatibility 0.1 package

This update's test gating status has been changed to 'waiting'.

a year ago

This update has been submitted for testing by bodhi.

a year ago

This update's test gating status has been changed to 'ignored'.

a year ago
User Icon salimma commented & provided feedback a year ago

Installation test succeeds:

bodhi updates download --updateid FEDORA-EPEL-2023-4c09a485b8
mock -r alma+epel-9-x86_64 install ./*.rpm
BZ#2103419 rust-terminal_size-0.2.3 is available

This update has been pushed to testing.

a year ago
User Icon decathorpe commented & provided feedback a year ago
karma

I don't know what you did, but running these exact commands gives me many errors:

Error: 
 Problem 1: conflicting requests
  - nothing provides (crate(fs-err/default) >= 2.6.0 with crate(fs-err/default) < 3.0.0~) needed by rust-io-lifetimes+fs-err-devel-1.0.3-1.el9.noarch
 Problem 2: conflicting requests
  - nothing provides (crate(os_pipe/default) >= 1.0.0 with crate(os_pipe/default) < 2.0.0~) needed by rust-io-lifetimes+os_pipe-devel-1.0.3-1.el9.noarch
  - nothing provides (crate(os_pipe/io_safety) >= 1.0.0 with crate(os_pipe/io_safety) < 2.0.0~) needed by rust-io-lifetimes+os_pipe-devel-1.0.3-1.el9.noarch
 Problem 3: package rust-rustix+os_pipe-devel-0.36.5-1.el9.noarch requires (crate(io-lifetimes/os_pipe) >= 1.0.0 with crate(io-lifetimes/os_pipe) < 2.0.0~), but none of the providers can be installed
  - conflicting requests
  - nothing provides (crate(os_pipe/default) >= 1.0.0 with crate(os_pipe/default) < 2.0.0~) needed by rust-io-lifetimes+os_pipe-devel-1.0.3-1.el9.noarch
  - nothing provides (crate(os_pipe/io_safety) >= 1.0.0 with crate(os_pipe/io_safety) < 2.0.0~) needed by rust-io-lifetimes+os_pipe-devel-1.0.3-1.el9.noarch
 Problem 4: package rust-rustix+fs-err-devel-0.36.5-1.el9.noarch requires (crate(io-lifetimes/fs-err) >= 1.0.0 with crate(io-lifetimes/fs-err) < 2.0.0~), but none of the providers can be installed
  - conflicting requests
  - nothing provides (crate(fs-err/default) >= 2.6.0 with crate(fs-err/default) < 3.0.0~) needed by rust-io-lifetimes+fs-err-devel-1.0.3-1.el9.noarch
 Problem 5: package rust-rustix+all-impls-devel-0.36.5-1.el9.noarch requires crate(rustix/fs-err) = 0.36.5, but none of the providers can be installed
  - package rust-rustix+fs-err-devel-0.36.5-1.el9.noarch requires (crate(io-lifetimes/fs-err) >= 1.0.0 with crate(io-lifetimes/fs-err) < 2.0.0~), but none of the providers can be installed
  - conflicting requests
  - nothing provides (crate(fs-err/default) >= 2.6.0 with crate(fs-err/default) < 3.0.0~) needed by rust-io-lifetimes+fs-err-devel-1.0.3-1.el9.noarch
 Problem 6: package rust-async-std+async-global-executor-devel-1.12.0-2.el9.noarch requires (crate(async-global-executor/async-io) >= 2.0.0 with crate(async-global-executor/async-io) < 3.0.0~), but none of the providers can be installed
  - package rust-async-global-executor+async-io-devel-2.3.1-1.el9.noarch requires crate(async-global-executor) = 2.3.1, but none of the providers can be installed
  - package rust-async-std+default-devel-1.12.0-2.el9.noarch requires crate(async-std/async-global-executor) = 1.12.0, but none of the providers can be installed
  - package rust-async-global-executor-devel-2.3.1-1.el9.noarch requires (crate(async-executor/default) >= 1.4.0 with crate(async-executor/default) < 2.0.0~), but none of the providers can be installed
  - package rust-io-lifetimes+async-std-devel-1.0.3-1.el9.noarch requires (crate(async-std/default) >= 1.12.0 with crate(async-std/default) < 2.0.0~), but none of the providers can be installed
  - package rust-async-executor+default-devel-1.4.1-4.el9.noarch requires crate(async-executor) = 1.4.1, but none of the providers can be installed
  - conflicting requests
  - nothing provides (crate(concurrent-queue/default) >= 1.2.2 with crate(concurrent-queue/default) < 2.0.0~) needed by rust-async-executor-devel-1.4.1-4.el9.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

a year ago

salimma edited this update.

New build(s):

  • rust-async-executor-1.5.0-1.el9

Karma has been reset.

a year ago

This update has been submitted for testing by salimma.

a year ago

salimma edited this update.

New build(s):

  • rust-fs-err-2.9.0-1.el9
  • rust-os_pipe-1.1.2-1.el9

Karma has been reset.

a year ago
User Icon decathorpe commented & provided feedback a year ago
karma

Can confirm, installs fine now.

BZ#2103419 rust-terminal_size-0.2.3 is available

This update has been pushed to testing.

a year ago

This update can be pushed to stable now if the maintainer wishes

a year ago

This update has been submitted for stable by salimma.

a year ago

This update has been pushed to stable.

a year ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
a year ago
in testing
a year ago
in stable
a year ago
modified
a year ago
BZ#2103419 rust-terminal_size-0.2.3 is available
0
1

Automated Test Results