Update librecad to 2.2.0 rc3. Apply fixes to libdxfrw and librecad for CVE-2021-45341, CVE-2021-45342, CVE-2021-45343. This also resolves the issue where some dwg files no longer opened.

This update has been submitted for testing by spot.

6 months ago

This update's test gating status has been changed to 'ignored'.

6 months ago

This update has been pushed to testing.

6 months ago

This update has been submitted for stable by bodhi.

6 months ago

This update has been pushed to stable.

6 months ago

Please login to add feedback.

Metadata
Type
security
Severity
low
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
6 months ago
in testing
6 months ago
in stable
6 months ago
BZ#2027148 librecad-2.2.0-rc3 is available
0
0
BZ#2031379 [regression] .dwg file no longer opens
0
0
BZ#2046249 CVE-2021-45341 librecad: buffer overflow in CDataMoji of the jwwlib component allows remote code execution via a crafted JWW document [epel-7]
0
0
BZ#2046253 CVE-2021-45342 librecad: buffer overflow in CDataList of the jwwlib component allows remote code execution via a crafted JWW document [epel-7]
0
0
BZ#2046257 CVE-2021-45343 librecad: NULL pointer dereference in the HATCH handling of libdxfrw can lead to DoS via a crafted DXF document [epel-7]
0
0

Automated Test Results