obsolete

composer-2.3.0-1.el9

FEDORA-EPEL-2022-11485e68a8 created by remi 2 years ago for Fedora EPEL 9

Version 2.3.0 - 2022-03-30

  • Fixed many strict types errors (#10646, #10642, #10647, #10658, #10656, #10665, #10660, #10663, #10662)

Version 2.3.0-RC2 - 2022-03-20

  • Fixed invalid return value in ComposerRepository::findPackage (#10622)
  • Fixed many show command issues due to a flipped condition (#10623)
  • Fixed phpversion() handling when it returns false due to an extension defining no version (#10631)
  • Fixed remove command failing when no allow-plugin is defined in config (#10629)
  • Performance improvement in Composer bootstrapping (version guessing) when on a feature branch (#10632)

Version 2.3.0-RC1 - 2022-03-16

  • BC Break: the minimum PHP version is now 7.2.5+, use the Composer 2.2 LTS if you are stuck with an older PHP (#10343)
  • BC Break: added native parameter & return types to many internal APIs, we explicitly left the most extended/implemented symbols untouched but if this causes problems nonetheless please report it ASAP (#10547, #10561)
  • BC Break: added visibility to all constants, a few internal ones have been made private/protected, if this causes problems please report it ASAP (#10550)
  • BC Break: the minimum supported Symfony components version is now 5.4, this only affects you if you are requiring composer/composer directly however, which is generally frowned upon
  • Bumped composer-plugin-api to 2.3.0
  • Bumped bundled Symfony components from 2.8 to 5.4 🥳
  • Added declare(strict_types=1) to all the classes, which for sure could cause regressions in edge cases, please report with stack traces (#10567)
  • Added --patch-only to the outdated command to only show updates to patch versions and ignore new major/minor versions (#10589)
  • Added clickable links to various commands for terminals which support it (#10430)
  • Added ProcessExecutor ability to receive commands as arrays by (internals/plugin change only) (#10435)
  • Added abandoned flag to show/outdated commands JSON-formatted output (#10485)
  • Added config.reference option to path repositories to configure the way the reference is generated, and possibly reduce composer.lock conflicts (#10488)
  • Added automatic removal of allow-plugins rules when removing a plugin via the remove command (#10615)
  • Added COMPOSER_IGNORE_PLATFOR_REQ & COMPOSER_IGNORE_PLATFOR_REQS env vars to configure the equivalent flags (#10616)
  • Added support for Symfony 6.0 components
  • Added support for psr/log 3.x (#10454)
  • Fixed symlink creation in linux VM guest filesystems to be recognized by Windows (#10592)
  • Performance improvement in pool optimization step (#10585)

Version 2.2.10 - 2022-03-29

  • Fixed Bitbucket authorization detection due to API changes (#10657)
  • Fixed validate command warning about dist/source keys if defined (#10655)
  • Fixed deletion/handling of corrupted 0-bytes zip archives (#10666)

This update has been submitted for testing by remi.

2 years ago

This update's test gating status has been changed to 'ignored'.

2 years ago

This update has obsoleted composer-2.2.10-1.el9, and has inherited its bugs and notes.

2 years ago

This update has been pushed to testing.

2 years ago

This update has been obsoleted by composer-2.3.2-1.el9.

2 years ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
2 years ago
in testing
2 years ago

Automated Test Results