testing

putty-0.81-1.fc40

FEDORA-2024-d85c1f7450 created by jskarvad 2 months ago for Fedora 40

Security fix for CVE-2024-31497.

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-d85c1f7450

This update has been submitted for testing by jskarvad.

2 months ago

This update's test gating status has been changed to 'ignored'.

2 months ago
User Icon tyrbiter commented & provided feedback 2 months ago
karma

Unable to install due to the following error:

Running transaction test Error: Transaction test error: file /usr/bin/pterm from install of putty-0.81-1.fc40.x86_64 conflicts with file from package prrte-3.0.2-4.fc40.x86_64 file /usr/share/man/man1/pterm.1.gz from install of putty-0.81-1.fc40.x86_64 conflicts with file from package prrte-3.0.2-4.fc40.x86_64

This update has been pushed to testing.

2 months ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 months ago
User Icon bojan commented & provided feedback a month ago
karma

Works.

User Icon nixuser commented & provided feedback a month ago
karma

Update is installing and working OK here.

BZ#2275179 putty-0.81 is available
User Icon jskarvad commented & provided feedback a month ago

Unable to install due to the following error:

Running transaction test Error: Transaction test error: file /usr/bin/pterm from install of putty-0.81-1.fc40.x86_64 conflicts with file from package prrte-3.0.2-4.fc40.x86_64 file /usr/share/man/man1/pterm.1.gz from install of putty-0.81-1.fc40.x86_64 conflicts with file from package prrte-3.0.2-4.fc40.x86_64

This conflict is caused by prrte package. It should be fixed in the prrte package and I was told it was fixed (I untested it). But it's definitely not putty problem. And it definitely doesn't appear during this update. Putty is shipping this file for ages, thus it is really not reason for negative karma of security update.

User Icon tyrbiter commented & provided feedback a month ago

A perfectly fair comment. However I didn't choose to install prrte, it came in during the F40 upgrade for some reason.

I will raise a bug for the prrte package, feel free to withdraw my negative karma, I suppose I should have made it neutral.

This update can be pushed to stable now if the maintainer wishes

a month ago

This update's test gating status has been changed to 'failed'.

a month ago

Please login to add feedback.

Metadata
Type
security
Severity
low
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
2 months ago
in testing
2 months ago
approved
a month ago
BZ#2275179 putty-0.81 is available
0
1
BZ#2275183 CVE-2024-31497 putty: secret key recovery of NIST P-521 private keys through biased ECDSA nonces in putty client
0
0
BZ#2275185 CVE-2024-31497 putty: secret key recovery of NIST P-521 private keys Through Biased ECDSA Nonces in PuTTY Client [fedora-all]
0
0

Automated Test Results