unpushed

sssd-2.9.4-1.fc40

FEDORA-2024-287a88fffd created by pbrezina 5 months ago for Fedora 40

Automatic update for sssd-2.9.4-1.fc40.

Changelog
* Fri Jan 12 2024 Pavel Březina <pbrezina@redhat.com> - 2.9.4-1
- Rebase to SSSD 2.9.4
- Files provider suport remove (rhbz#2253183)
- i686 support removed (rhbz#2069738)

This update was automatically created

5 months ago

This update's test gating status has been changed to 'waiting'.

5 months ago
User Icon decathorpe commented & provided feedback 5 months ago
karma

I don't think dropping i686 support here is a good idea. I'm quite certain this is not a leaf package, so it's also not covered by the linked change proposal.

This update's test gating status has been changed to 'passed'.

5 months ago
User Icon pbrezina commented & provided feedback 5 months ago

@decathorpe SSSD depends on gdm-pam-extensions-devel which is no longer available on i686, additionally AFAIK we never supported multilib, so I think it is fine to drop it.

We could add conditional BuildRequires to skip gdm-pam-extensions-devel on i686 but that is discouraged as well.

So please advice.

User Icon decathorpe commented & provided feedback 5 months ago

The problem is not multilib, but pure-i686 environments, mostly buildroots for building other packages that depend on any of the binary packages that are produced by sssd.

$ ./leafdrop sssd
libsss_autofs is Required by:
- freeipa-client
libsss_autofs is BuildRequired by:
- autofs
libsss_nss_idmap-devel is BuildRequired by:
- slapi-nis
libsss_sudo is Required by:
- freeipa-client
python3-libipa_hbac is Required by:
- python3-ipalib
python3-libsss_nss_idmap is BuildRequired by:
- freeipa
- freeipa-healthcheck
python3-sss-murmur is Required by:
- python3-ipalib
python3-sssdconfig is Required by:
- freeipa-client
- ipsilon-infosssd
- python3-ipaserver
- python3-ipatests
sssd is Required by:
- ipsilon-infosssd
sssd-client is Required by:
- appliance-tools
- python-imgcreate-sysdeps
sssd-idp is Required by:
- freeipa-client
sssd-ipa is Required by:
- freeipa-client
sssd-krb5 is Required by:
- freeipa-client
sssd-tools is Required by:
- freeipa-client
sssd-winbind-idmap is Required by:
- freeipa-client-samba
NO: Package sssd is not a leaf package on i686.

Any of the packages listed here will have problems getting installed and / or built on i686 if this update lands in rawhide as-is.

If you are only dropping i686 support because gdm-pam-extensions-devel is no longer available on that architecture, please file a bug against that package instead - they should not have dropped i686 support either.

User Icon pbrezina commented & provided feedback 5 months ago

This update has been unpushed.


Please login to add feedback.

Metadata
Type
unspecified
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
0 days
Dates
submitted
5 months ago
in testing
5 months ago
BZ#2069738 Encourage Dropping Unused / Leaf Packages on i686
0
0
BZ#2253183 Rebuild package without `--with-files-provider` ./configure option
0
0

Automated Test Results