obsolete

matio-1.5.24-1.fc38

FEDORA-2023-d42e733d36 created by limb 7 months ago for Fedora 38

1.5.24

This update has been submitted for testing by limb.

7 months ago

This update's test gating status has been changed to 'ignored'.

7 months ago

This update has been pushed to testing.

7 months ago
User Icon sharkcz commented & provided feedback 7 months ago
karma

update fails on an up-to-date F-38 because nothing provides pkgconfig(hdf5) >= 1.8 needed by matio-devel-1.5.24-1.fc38.ppc64le from updates-testing

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

7 months ago
User Icon imabug commented & provided feedback 7 months ago
karma

Got this error during upgrade

Problem 1: cannot install the best update candidate for package matio-devel-1.5.23-3.fc38.x86_64
- nothing provides pkgconfig(hdf5) >= 1.8 needed by matio-devel-1.5.24-1.fc38.x86_64 from updates-testing
Problem 2: problem with installed package matio-devel-1.5.23-3.fc38.x86_64
- package matio-devel-1.5.23-3.fc38.x86_64 from fedora requires matio = 1.5.23-3.fc38, but none of the providers can be installed
- package matio-devel-1.5.23-3.fc38.x86_64 from @System requires matio = 1.5.23-3.fc38, but none of the providers can be installed
- matio-1.5.23-3.fc38.i686 from fedora  does not belong to a distupgrade repository
- cannot install both matio-1.5.24-1.fc38.x86_64 from updates-testing and matio-1.5.23-3.fc38.x86_64 from @System
- cannot install both matio-1.5.24-1.fc38.x86_64 from updates-testing and matio-1.5.23-3.fc38.x86_64 from fedora
- cannot install the best update candidate for package matio-1.5.23-3.fc38.x86_64
- nothing provides pkgconfig(hdf5) >= 1.8 needed by matio-devel-1.5.24-1.fc38.x86_64 from updates-testing
User Icon limb commented & provided feedback 7 months ago

Odd, the matio spec doesn't explicitly specify pkgconfig(hdf5), simply hdf5-devel.

User Icon sharkcz commented & provided feedback 7 months ago

Isn't it automagically generated? I see

Requires    
/usr/bin/pkg-config
hdf5-devel
libmatio.so.11()(64bit)
matio = 1.5.24-1.fc38
pkgconfig
pkgconfig(hdf5) >= 1.8
pkgconfig(zlib) >= 1.2.3
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
zlib-devel
User Icon sharkcz commented & provided feedback 7 months ago

/usr/lib64/pkgconfig/matio.pc contains Requires.private: hdf5 >= 1.8 zlib >= 1.2.3 which is wrong for a shared lib, I believe

User Icon limb commented & provided feedback 6 months ago

Patching that our doesn't remove the pkgconfig(hdf5) Requires...I guess I'm wondering, if rpm is automatically generating this requirement, shouldn't it also be generating the equivalent Provides on the hdf5 subpackage?

This update has been obsoleted by matio-1.5.24-2.fc38.

6 months ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
low
Karma
-2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
7 months ago
in testing
7 months ago
BZ#2246703 matio-1.5.24 is available
0
0

Automated Test Results