obsolete

rubygem-http_parser.rb-0.8.0-1.fc38

FEDORA-2023-a9ccd1bf30 created by ilgrad 7 months ago for Fedora 38

update to new version 0.8.0

This update has been submitted for testing by ilgrad.

7 months ago

This update's test gating status has been changed to 'ignored'.

7 months ago
User Icon ilgrad provided feedback 7 months ago
BZ#1978604 rubygem-http_parser.rb-0.8.0 is available

This update has been pushed to testing.

7 months ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

7 months ago
User Icon vondruch commented & provided feedback 7 months ago

@jackorp seems you have bumped the rubygem-em-websocket in Rawhide, any plan to address also F38?

User Icon vondruch commented & provided feedback 6 months ago

It also likely breaks rubygem-em-http-request:

https://koji.fedoraproject.org/koji/taskinfo?taskID=104228101

@jackopr ^^

User Icon besser82 commented & provided feedback 6 months ago
karma
Problem: package rubygem-em-websocket-1:0.5.2-6.fc38.noarch requires (rubygem(http_parser.rb) >= 0.6.0 with rubygem(http_parser.rb) < 0.7), but none of the providers can be installed
  - cannot install both rubygem-http_parser.rb-0.6.0-27.fc38.x86_64 and rubygem-http_parser.rb-0.8.0-1.fc38.x86_64
  - cannot install the best update candidate for package rubygem-http_parser.rb-0.6.0-27.fc38.x86_64
  - cannot install the best update candidate for package rubygem-em-websocket-1:0.5.2-6.fc38.noarch
User Icon jackorp commented & provided feedback 6 months ago
karma

jackorp seems you have bumped the rubygem-em-websocket in Rawhide, any plan to address also F38?

This one is easy to address, even upstream release is simply patching the requirement in gemspec. I have bumped rawhide as there the action does not seem a great risk of a bump.

hmm, I seem to not receive emails from bodhi when I am tagged...

It also likely breaks rubygem-em-http-request:

More than likely. Suddenly a callback is getting called twice and it's tripping up the code, when I "fix" that test, I have new failure... I have to vote against including this in a stable Fedora release.

This update has been obsoleted.

6 months ago

Please login to add feedback.

Metadata
Type
unspecified
Severity
medium
Karma
-3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
7 months ago
in testing
7 months ago
BZ#1978604 rubygem-http_parser.rb-0.8.0 is available
0
1

Automated Test Results