stable

python-lsp-server-1.9.0-1.fc39, python-qdarkstyle-3.2.1-1.fc39, & 3 more

FEDORA-2023-3907f943d7 created by gui1ty 7 months ago for Fedora 39

Update spyder to 5.5.0.

Dependencies updated

  • lsp-server
  • qdarkstyle
  • spyder-kernels
  • qtconsole

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2023-3907f943d7

This update's test gating status has been changed to 'waiting'.

7 months ago

This update has been submitted for testing by bodhi.

7 months ago

This update's test gating status has been changed to 'ignored'.

7 months ago

gui1ty edited this update.

7 months ago

This update has been pushed to testing.

7 months ago

Should not this be shipped with the updated spyder version?

Problem 1: package python3-spyder-5.4.5-23.fc39.noarch requires (python3.12dist(python-lsp-server) < 1.9~~ with python3.12dist(python-lsp-server) >= 1.8), but none of the providers can be installed
  - cannot install both python3-lsp-server-1.8.2-1.fc39.noarch and python3-lsp-server-1.9.0-1.fc39.noarch
  - cannot install both python3-lsp-server-1.8.0-6.fc39.noarch and python3-lsp-server-1.9.0-1.fc39.noarch
  - cannot install the best update candidate for package python3-spyder-5.4.5-23.fc39.noarch
  - cannot install the best update candidate for package python3-lsp-server-1.8.2-1.fc39.noarch
 Problem 2: problem with installed package
  - package python3-spyder-5.4.5-23.fc39.noarch requires (python3.12dist(python-lsp-server[all]) < 1.9~~ with python3.12dist(python-lsp-server[all]) >= 1.8), but none of the providers can be installed
  - cannot install both python3-lsp-server+all-1.8.2-1.fc39.noarch and python3-lsp-server+all-1.9.0-1.fc39.noarch
  - cannot install both python3-lsp-server+all-1.8.0-6.fc39.noarch and python3-lsp-server+all-1.9.0-1.fc39.noarch
  - cannot install the best update candidate for package python3-lsp-server+all-1.8.2-1.fc39.noarch

Well, the new spyder release (5.5.0) requires the newer python-lsp-server and the updates to the other dependencies in this update bundle. Yes, the current version of spyder will break if python-lsp-server were to be pushed all by itself.

Or am I missing something here? What's the command you ran, that gave above output?

Oh wait, spyder itself is missing. Dang! Let me fix that.

dnf5 upgrade

What I am saying is that for the upgrade path to work spyder 5.5 should be added to this bundle.

Absolutely! What a stupid mistake to make. It's building as I type. Thanks for pointing it out.

gui1ty edited this update.

New build(s):

  • spyder-5.5.0-1.fc39

Karma has been reset.

7 months ago

This update has been submitted for testing by gui1ty.

7 months ago

Now also including the update for spyder itself. ;)

User Icon jamatos commented & provided feedback 7 months ago
karma

Thank you. Obviously after this the update works as it should.

Again thank you for working on this. It is appreciated. :-)

This update has been pushed to testing.

7 months ago

This update has been submitted for stable by bodhi.

7 months ago

This update has been pushed to stable.

7 months ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
7 months ago
in testing
7 months ago
in stable
7 months ago
modified
7 months ago
approved
7 months ago

Automated Test Results