stable

lorax-35.9-2.fc35 and pipewire-0.3.43-1.fc35

FEDORA-2022-4cf1bb6eed created by wtaymans 11 months ago for Fedora 35

Update version to 0.3.43. The updated lorax is needed to handle issues caused in the installer environment creation process by changes to pipewire.

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2022-4cf1bb6eed

This update has been submitted for testing by wtaymans.

11 months ago

This update's test gating status has been changed to 'waiting'.

11 months ago
User Icon miniprise commented & provided feedback 11 months ago
karma

fixes seeking issues in gstreamer applications (clapper, podcasts changing playback speed etc.)

This update's test gating status has been changed to 'failed'.

11 months ago
$ sudo dnf localinstall pipewire-plugin-jack-0.3.43-1.fc35.x86_64.rpm 
Last metadata expiration check: -1 day, 22:05:20 ago on Ср 05 янв 2022 20:29:00.
Error: 
 Problem: package pipewire-plugin-jack-0.3.43-1.fc35.x86_64 requires jack-audio-connection-kit, but none of the providers can be installed
  - package pipewire-jack-audio-connection-kit-0.3.38-1.fc35.x86_64 conflicts with jack-audio-connection-kit provided by jack-audio-connection-kit-1.9.19-1.fc35.i686
  - package pipewire-jack-audio-connection-kit-0.3.38-1.fc35.x86_64 conflicts with jack-audio-connection-kit provided by jack-audio-connection-kit-1.9.19-1.fc35.x86_64
  - problem with installed package pipewire-jack-audio-connection-kit-0.3.43-1.fc35.x86_64
  - conflicting requests
  - package pipewire-jack-audio-connection-kit-0.3.40-1.fc35.x86_64 conflicts with jack-audio-connection-kit provided by jack-audio-connection-kit-1.9.19-1.fc35.i686
  - package pipewire-jack-audio-connection-kit-0.3.40-1.fc35.x86_64 conflicts with jack-audio-connection-kit provided by jack-audio-connection-kit-1.9.19-1.fc35.x86_64
  - package pipewire-jack-audio-connection-kit-0.3.43-1.fc35.x86_64 conflicts with jack-audio-connection-kit provided by jack-audio-connection-kit-1.9.19-1.fc35.i686
  - package pipewire-jack-audio-connection-kit-0.3.43-1.fc35.x86_64 conflicts with jack-audio-connection-kit provided by jack-audio-connection-kit-1.9.19-1.fc35.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

not sure if it's some local issue or not

$ rpm -qa | grep -E '(jack|pipewire)' | sort 
pipewire-0.3.43-1.fc35.x86_64
pipewire-alsa-0.3.43-1.fc35.x86_64
pipewire-gstreamer-0.3.43-1.fc35.x86_64
pipewire-jack-audio-connection-kit-0.3.43-1.fc35.x86_64
pipewire-jack-audio-connection-kit-devel-0.3.43-1.fc35.x86_64
pipewire-libs-0.3.43-1.fc35.x86_64
pipewire-pulseaudio-0.3.43-1.fc35.x86_64
pipewire-utils-0.3.43-1.fc35.x86_64
qemu-audio-jack-6.1.0-13.fc35.x86_64

@ojab not sure if it's some local issue or not

This is normal, if you want to install the jack plugin (to work with real jack) you need to uninstall the pipewire-jack emulation. So:

sudo dnf swap pipewire-jack-audio-connection-kit jack-audio-connection-kit

and then

sudo dnf install pipewire-plugin-jack

should work

User Icon ojab provided feedback 11 months ago
karma

Once again, this update does not include the lorax build it needs to include in order to pass testing (and not break installer image generation). I have explained this multiple times, but you keep ignoring it.

This update has been pushed to testing.

11 months ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

11 months ago
User Icon gourlaysama commented & provided feedback 11 months ago
karma
karma
User Icon amdgpu provided feedback 11 months ago
karma

adamwill edited this update.

New build(s):

  • lorax-35.9-2.fc35

Karma has been reset.

11 months ago

This update has been submitted for testing by adamwill.

11 months ago

I bumped lorax with no changes and edited it into this update. That should solve the test failures.

This update's test gating status has been changed to 'passed'.

11 months ago
User Icon treba provided feedback 11 months ago
karma
karma

This update has been pushed to testing.

11 months ago

This update can be pushed to stable now if the maintainer wishes

11 months ago

This update's test gating status has been changed to 'failed'.

11 months ago
User Icon besser82 commented & provided feedback 11 months ago
karma

Works great! LGTM! =)

@adamwill I guess I need to add the lorax update in buildroot, then rebuild pipewire and then add pipewire to buildroot, if I want to rebuild wireplumber?

User Icon bojan commented & provided feedback 11 months ago
karma

Works.

User Icon frantisekz commented & provided feedback 11 months ago
karma

Works nicely!

@wtaymans not sure what you're asking exactly, but in any case, lorax should never need to be in the buildroot as the problematic test doesn't get run at build time. It gets run when an update is submitted or edited. As long as lorax is in the update alongside pipewire, that problem shouldn't be there. Once this update goes stable, the newer pipewire and lorax will both be in the stable updates repo and there will be no need to worry about this issue any more.

The gating failure here seems to be due to a CI failure trying to test the lorax build (it has an error about test environment installation failing). I'll hit the 're-trigger tests' button and see if it sorts that out.

User Icon atim provided feedback 11 months ago
karma

@adamwill

The gating failure here seems to be due to a CI failure trying to test the lorax build (it has an error about test environment installation failing). I'll hit the 're-trigger tests' button and see if it sorts that out.

Attempting to add pipewire to buildroot gives me "Nvr : Cannot create a buildroot override if build's test gating status is failed."

Once this update goes stable, the newer pipewire and lorax will both be in the stable updates repo and there will be no need to worry about this issue any more.

I can't seem to push this to stable..

User Icon lruzicka commented & provided feedback 11 months ago
karma

Works ok.

@wtaymans ah OK, so all of those are the same problem: we've got a failed gating test. It's the fedora-ci.koji-build.tier0.functional test for lorax. lorax's gating.yaml sets that test as required (it isn't by default), which is why it's resulting in failed gating status.

I tried re-running it and it failed again. The failure is in test environment setup, I don't know what's going wrong. I've mailed the CI list about it. For now we can just waive the failure, I think, which would both let us push the update stable and let you submit a buildroot override (but that won't be necessary if we do the stable push). I'll submit the waiver and push the update stable.

This update's test gating status has been changed to 'waiting'.

11 months ago

This update's test gating status has been changed to 'passed'.

11 months ago

This update has been submitted for stable by adamwill.

11 months ago

This update has been pushed to stable.

11 months ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
7
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
11 months ago
in testing
11 months ago
in stable
11 months ago
modified
11 months ago

Automated Test Results

passed