unpushed

FEDORA-2021-bd7b8f9a8f created by catanzaro a year ago for Fedora 35

Update to WebKitGTK 2.34.1:

  • Update user agent browser versions.
  • Fix a crash with GTK >= 3.24.30.
  • Fix a crash when loading videos on reddit.
  • Fix file type detection when application calls g_desktop_app_info_set_as_default_for_extension() passing html.
  • Security fixes: CVE-2021-42762

This update has been submitted for testing by catanzaro.

a year ago

This update's test gating status has been changed to 'failed'.

a year ago

This update's test gating status has been changed to 'waiting'.

a year ago

This update's test gating status has been changed to 'failed'.

a year ago

This update's test gating status has been changed to 'passed'.

a year ago

This update has been pushed to testing.

a year ago
User Icon mtasaka commented & provided feedback a year ago
karma

Would you don't do this kind of compatibility change at this timing, or would you modify all dependent package not to break things?
https://src.fedoraproject.org/rpms/webkit2gtk3/c/cd0667007e834434cfec9209a91e624f9f9b143f?branch=f35

Problem: package osmo-0.4.2-2.fc35.x86_64 requires webkitgtk4, but none of the providers can be installed
  - webkit2gtk3-2.34.0-1.fc35.i686 has inferior architecture
  - cannot install both webkit2gtk3-2.34.1-1.fc35.x86_64 and webkit2gtk3-2.34.0-1.fc35.x86_64
  - cannot install both webkit2gtk3-2.34.0-1.fc35.x86_64 and webkit2gtk3-2.34.1-1.fc35.x86_64
  - cannot install the best update candidate for package webkit2gtk3-2.34.0-1.fc35.x86_64
  - cannot install the best update candidate for package osmo-0.4.2-2.fc35.x86_64

The affected packages are at least:

# dnf repoquery --quiet --repo=koji-35 --whatrequires webkitgtk4
exfalso-0:4.5.0-0.1.fc35.noarch
gphotoframe-0:2.0.2-13.hg2084299dffb6.fc35.noarch
osmo-0:0.4.2-2.fc35.x86_64
rednotebook-0:2.22-3.fc35.noarch
sugar-0:0.118-5.fc35.noarch
sugar-browse-0:207-2.fc35.noarch
ulauncher-0:5.14.0-1.fc35.noarch

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

a year ago

Would you don't do this kind of compatibility change at this timing, or would you modify all dependent package not to break things? https://src.fedoraproject.org/rpms/webkit2gtk3/c/cd0667007e834434cfec9209a91e624f9f9b143f?branch=f35

Oh, wow. OK, I will respin this update to avoid breaking things in F35.

I'll keep this change in rawhide, but I'll send pull requests to affected packages.

This update has been unpushed.

I'll keep this change in rawhide, but I'll send pull requests to affected packages.

I changed my mind. It's easier to just keep the Obsoletes.


Please login to add feedback.

Metadata
Type
security
Severity
medium
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
a year ago
in testing
a year ago

Automated Test Results