obsolete

python-cryptography-35.0.0-2.fc35, python-jwt-2.1.0-3.fc35, & 8 more

FEDORA-2021-122248d76a created by cheimes 2 years ago for Fedora 35

Update python-cryptography and Rust dependencies

This update's test gating status has been changed to 'waiting'.

2 years ago

This update has been submitted for testing by bodhi.

2 years ago

This update's test gating status has been changed to 'ignored'.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon alebastr commented & provided feedback 2 years ago
 Problem: package python3-jwt+crypto-2.1.0-2.fc35.noarch requires (python3.10dist(cryptography) < 4 with python3.10dist(cryptography) >= 3.3.1), but none of the providers can be installed
  - cannot install both python3-cryptography-35.0.0-2.fc35.x86_64 and python3-cryptography-3.4.7-5.fc35.x86_64
  - cannot install the best update candidate for package python3-jwt+crypto-2.1.0-2.fc35.noarch
  - cannot install the best update candidate for package python3-cryptography-3.4.7-5.fc35.x86_64
User Icon cheimes commented & provided feedback 2 years ago

The issue is fixed by jwt upstream commit https://github.com/GehirnInc/python-jwt/pull/45 and release 1.3.0.

User Icon zbyszek commented & provided feedback 2 years ago
karma

A rebuild of python-jwt needs to be included in this update with the patch.

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago
User Icon cheimes commented & provided feedback 2 years ago

I asked upstream to drop or at least relax the upper bound, https://github.com/GehirnInc/python-jwt/issues/46 . It doesn't make sense with new version scheme.

User Icon pbrobinson commented & provided feedback 2 years ago
karma

Problem: package python3-jwt+crypto-2.1.0-2.fc35.noarch requires (python3.10dist(cryptography) < 4 with python3.10dist(cryptography) >= 3.3.1), but none of the providers can be installed - cannot install both python3-cryptography-35.0.0-2.fc35.x86_64 and python3-cryptography-3.4.7-5.fc35.x86_64 - cannot install the best update candidate for package python3-jwt+crypto-2.1.0-2.fc35.noarch - cannot install the best update candidate for package python3-cryptography-3.4.7-5.fc35.x86_64

User Icon kevin commented & provided feedback 2 years ago

I have just pushed a update that removes the upper bound for now until upstream decides what they want to do here., for rawhide, do you want to merge into f35 and build for f35 (and attach here)?

User Icon oturpe commented & provided feedback 2 years ago

@cheimes Wrong python-jwt! What is called python-jwt in Fedora is actually this project: https://github.com/jpadilla/pyjwt

There is a fix for this there, too: https://github.com/jpadilla/pyjwt/commit/19ce9c5ec7947428d35aaffd302eb2629210a697

User Icon cheimes commented & provided feedback 2 years ago

@kevin Could you please build python-jwt-2.1.0-3.fc35? I'll add the build to this update.

User Icon kevin commented & provided feedback 2 years ago

fedpkg build --target f35-build-side-46299 Building python-jwt-2.1.0-3.fc35 for f35-build-side-46299 Created task: 76693789 Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=76693789 Should be built in a few. ;)

zbyszek edited this update.

New build(s):

  • python-jwt-2.1.0-3.fc35

Karma has been reset.

2 years ago

This update has been submitted for testing by zbyszek.

2 years ago
User Icon cheimes commented & provided feedback 2 years ago
User Icon cheimes provided feedback 2 years ago

This update has been pushed to testing.

2 years ago
User Icon besser82 commented & provided feedback 2 years ago
karma

Works great! LGTM! =)

User Icon cheimes commented & provided feedback 2 years ago

Everybody, please give NEGATIVE Karma to this update request.

cryptography 35.0.0 is causing a breaking change with FreeIPA. I'm unable to retract the update although I created it. I assume it's related to @zbyszek push and submisssion.

User Icon rcritten provided feedback 2 years ago
karma
BZ#2009117 python-cryptography-35.0.0 is available
User Icon abbra commented & provided feedback 2 years ago
karma

breaks FreeIPA.

BZ#2009117 python-cryptography-35.0.0 is available
User Icon abiagion provided feedback 2 years ago
karma
User Icon adamwill provided feedback 2 years ago
karma

This update has been obsoleted.

2 years ago
karma
BZ#2010061 F35FailsToInstall: python3-jwt+crypto

Please login to add feedback.

Metadata
Type
enhancement
Karma
-4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
modified
2 years ago
BZ#2005948 New version of python-cryptography: 3.4.8 newer than 3.4.7
0
0
BZ#2007661 rust-ouroboros-0.12.0 is available
0
0
BZ#2007662 rust-ouroboros_macro-0.12.0 is available
0
0
BZ#2009117 python-cryptography-35.0.0 is available
-2
0
BZ#2010061 F35FailsToInstall: python3-jwt+crypto
-1
0

Automated Test Results