stable

rubygem-rack-2.0.4-4.fc29

FEDORA-2018-e8ff8b7f8e created by vondruch 4 years ago for Fedora 29
  • Buffer size in multipart parser allows for denial of service (CVE-2018-16470).
  • Cross-site scripting (XSS) via scheme method on Rack::Request (CVE-2018-16471).

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2018-e8ff8b7f8e

This update has been submitted for testing by vondruch.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon besser82 commented & provided feedback 4 years ago
karma

Works great! LGTM! =)

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

4 years ago

This update has been submitted for batched by vondruch.

4 years ago

This update has been submitted for stable by bodhi.

4 years ago

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
security
Severity
medium
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
BZ#1646814 CVE-2018-16470 rubygem-rack: Buffer size in multipart parser allows for denial of service
0
0
BZ#1646815 CVE-2018-16470 rubygem-rack: Buffer size in multipart parser allows for denial of service [fedora-all]
0
0
BZ#1646818 CVE-2018-16471 rubygem-rack: Cross-site scripting (XSS) via `scheme` method on `Rack::Request`
0
0
BZ#1646819 CVE-2018-16471 rubygem-rack: Cross-site scripting (XSS) via `scheme` method on `Rack::Request` [fedora-all]
0
0

Automated Test Results

ignored