FEDORA-2018-baa8315daa

security update in Fedora 27 for mingw-LibRaw

Status: stable 2 months ago

Update to LibRaw-0.18.13, see https://www.libraw.org/news/libraw-0-18-13 for details. Fixes CVE-2018-5815, CVE-2018-5816.

Comments 7

This update has been submitted for testing by smani.

This update has been pushed to testing.

thanks for the update.

fyi: the CVEs mentioned have been fixed in libraw 0.18.12 as far as I know. 0.18.13 fixes two additional possible vulns w/o CVE 1. fixed possible stack overrun while reading zero-sized strings, maybe this

https://github.com/LibRaw/LibRaw/commit/e25a09e42bc05a666a28f5f55bfad02f69567712 2. fixed possible integer overflow, maybe this: https://github.com/LibRaw/LibRaw/commit/2aabf1b68a8a1dc953ca698ba79f89a80f0f5150

see

https://github.com/LibRaw/LibRaw/compare/0.18.12...0.18.13

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

This update has been submitted for batched by smani.

This update has been submitted for stable by bodhi.

This update has been pushed to stable.


Add Comment & Feedback
Toggle Preview

Comment fields support Fedora-Flavored Markdown. Comments are governed under this privacy policy.

-1 0 +1 Feedback Guidelines

Is the update generally functional? (karma)

You need to be logged in to add karma!

#1610151 CVE-2018-5815 LibRaw: Integer overflow in internal/dcraw_common.cpp:parse_qt() allows for denial of service
#1610153 CVE-2018-5815 mingw-LibRaw: LibRaw: Integer overflow in internal/dcraw_common.cpp:parse_qt() allows for denial of service [fedora-all]
#1610156 CVE-2018-5816 LibRaw: Integer overflow in internal/dcraw_common.cpp:identify() allows for denial of service
#1610158 CVE-2018-5816 mingw-LibRaw: LibRaw: Integer overflow in internal/dcraw_common.cpp:identify() allows for denial of service [fedora-all]
Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
security
Update Severity
unspecified
Karma
0
stable threshold: 3
unstable threshold: -3
Autopush
Enabled
Dates
submitted 3 months ago
in testing 3 months ago
in stable 2 months ago

Related Bugs 4

00 #1610151 CVE-2018-5815 LibRaw: Integer overflow in internal/dcraw_common.cpp:parse_qt() allows for denial of service
00 #1610153 CVE-2018-5815 mingw-LibRaw: LibRaw: Integer overflow in internal/dcraw_common.cpp:parse_qt() allows for denial of service [fedora-all]
00 #1610156 CVE-2018-5816 LibRaw: Integer overflow in internal/dcraw_common.cpp:identify() allows for denial of service
00 #1610158 CVE-2018-5816 mingw-LibRaw: LibRaw: Integer overflow in internal/dcraw_common.cpp:identify() allows for denial of service [fedora-all]

Automated Test Results