FEDORA-2018-993bc1829a created by raphgro 3 years ago for Fedora 27
stable

v5.4.0, with support for mime

-- fix a bug that caused a wrong password to be used when creating a TrueCrypt/VeraCrypt volume from zuluCrypt-gui. Easiest way to notice this was that a just created volume could not be unlocked.

-- fix a build issue on some distributions.

v5.3.0

-- Fix a build time error when build with certain new compilers and a runtime crush when build with other newer compilers.

-- Add more support for wayland sessions by not requiring GUI to run from root's account to perform some operations.

-- Add support for creating LUKS2 volumes(libcryptsetup >=2.0.0 is required)

-- Add support for unlocking of TrueCrypt and VeraCrypt volumes without mounting their file system.

    -- Unlocking of a TrueCrypt volume is done by command: 
                zuluCrypt-cli -O -d /dev/sdXX -t tcrypt

    -- Unlocking of a VeraCrypt volume is done by command: 
                zuluCrypt-cli -O -d /dev/sdXX -t vcrypt

Logout Required
After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-993bc1829a

This update has been submitted for testing by raphgro.

3 years ago
User Icon anonymous commented & provided feedback 3 years ago

Hallo,

can You please clarify what's the security impact of this update? Is there a vulnerability fixed with this release? Can't find anything in the release notes of zulucrypt 5.4.0 or 5.3.0 and the things You mention seem to be (unpleasant) software bugs. Can an attacker trigger those?

Cheers

User Icon raphgro commented & provided feedback 3 years ago

Hallo, please first learn how to do polite greetings in english. Thanks!

raphgro edited this update.

3 years ago
User Icon raphgro commented & provided feedback 3 years ago

Set wrong bit by mistake, sorry.

This update has been pushed to testing.

3 years ago
User Icon anonymous commented & provided feedback 3 years ago

Dear Sir or Madam,

thanks for the clarification, I did not mean to upset You.

Best regards

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

3 years ago

This update has been submitted for batched by raphgro.

3 years ago

Bodhi is unable to request this update for stabilization: This update has not yet met the minimum testing requirements defined in the Package Update Acceptance Criteria

3 years ago

This update has been submitted for stable by raphgro.

3 years ago

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
2
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
modified
3 years ago
BZ#1508253 zulucrypt-5.4.0 is available
0
0

Automated Test Results