FEDORA-2018-051bee7533 created by pbrobinson 5 years ago for Fedora 28

Update to 18.0.0 rc5

This update has been submitted for testing by pbrobinson.

5 years ago

This update has been pushed to testing.

5 years ago
User Icon fatka commented & provided feedback 5 years ago

I can't install this update. I get dependency errors as in the failing test. Maybe it should require "libLLVM-6.0.so()(64bit)" instead?

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

5 years ago

We might want to just add this into the llvm update for f28. f28 currently has llvm-6.0.0-rc2, but I think this build of Mesa was built while I had the llvm-6.0.0 override enabled.

Actually we should just re-test once https://bodhi.fedoraproject.org/updates/FEDORA-2018-689de58112 goes stable if that is the problem. I don't want to modify that update and reset the karma.

Same here!

Last metadata expiration check: 0:00:00 ago on Wed 28 Mar 2018 10:41:03 AM CEST. Dependencies resolved.

Problem 1: cannot install the best update candidate for package mesa-dri-drivers-18.0.0-0.3.rc4.fc28.x86_64 * nothing provides libLLVM-6.0.so(LLVM_6.0)(64bit) needed by mesa-dri-drivers-18.0.0-0.5.rc5.fc28.x86_64

Problem 2: cannot install the best update candidate for package mesa-vdpau-drivers-18.0.0-0.3.rc4.fc28.x86_64 * nothing provides libLLVM-6.0.so(LLVM_6.0)(64bit) needed by mesa-vdpau-drivers-18.0.0-0.5.rc5.fc28.x86_64

Problem 3: problem with installed package mesa-vdpau-drivers-18.0.0-0.3.rc4.fc28.x86_64 * package mesa-vdpau-drivers-18.0.0-0.3.rc4.fc28.x86_64 requires mesa-filesystem(x86-64) = 18.0.0-0.3.rc4.fc28, but none of the providers can be installed * cannot install both mesa-filesystem-18.0.0-0.5.rc5.fc28.x86_64 and mesa-filesystem-18.0.0-0.3.rc4.fc28.x86_64 * cannot install both mesa-filesystem-18.0.0-0.3.rc4.fc28.x86_64 and mesa-filesystem-18.0.0-0.5.rc5.fc28.x86_64 * cannot install the best update candidate for package mesa-filesystem-18.0.0-0.3.rc4.fc28.x86_64 * nothing provides libLLVM-6.0.so(LLVM_6.0)(64bit) needed by mesa-vdpau-drivers-18.0.0-0.5.rc5.fc28.x86_64

User Icon lupinix commented & provided feedback 5 years ago

Same for me

User Icon piotrdrag commented & provided feedback 5 years ago

Broken dependencies.

This update has been obsoleted.

5 years ago

Could you finally get this fixed ? I keep getting broken deps for days. And your Beta F28 will be out in 3 days. What will people think, if they can't get their system updated correctly.

karma: -1

The problem here is that the LLVM 6 update was pushed stable, but the nightly compose that day failed. So LLVM 6 is not in updates-testing any more (it was removed when it was pushed stable) and it is also not in fedora (because the stable compose failed). It's nowhere.

This is really just a very unfortunate coincidence of the buildroot override and update systems...usually what I'd say in this case is that interdependent packages need to be in the same update, but it wasn't easy for @pbrobinson to notice that this build actually was interdependent with the LLVM 6 update, as he wasn't aiming for that, it just happened to get built while the LLVM 6 buildroot override was active.

If anything this is probably a good reason why we should replace the buildroot override system with something more targeted and based around tags, so we don't wind up with cases like this...

For now the bug is gone because this update has been unpushed from u-t. Once we get a successful compose with the LLVM 6 update in it, this can be pushed again.

We've had a successful compose and LLVM 6 is now in the main F28 repo, so this could be re-submitted.

I have add the most recent mesa build to the latest LLVM update: https://bodhi.fedoraproject.org/updates/FEDORA-2018-02c4091319

Please login to add feedback.

Content Type
Test Gating
Unstable by Karma
Stable by Karma
Stable by Time
5 years ago
in testing
5 years ago

Automated Test Results