stable

FEDORA-2017-a1dc0ef38c created by jsynacek 4 years ago for Fedora 26

#1490649 - emacs-25.3 is available

#1490410 - unsafe enriched mode translations (security)

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2017-a1dc0ef38c

This update has been submitted for testing by jsynacek.

4 years ago
User Icon dhgutteridge commented & provided feedback 4 years ago

This conflicts with https://bodhi.fedoraproject.org/updates/FEDORA-2017-8f27031c8f if one already has that installed from updates-testing. (I do.)

User Icon jsynacek commented & provided feedback 4 years ago

How can it conflict? The upgrade path is clear and the patch wasn't there in the git repo. I wasn't even aware that someone released emacs in a mass update like that.

This update has been pushed to testing.

4 years ago
User Icon cserpentis commented & provided feedback 4 years ago
karma

works for me

User Icon besser82 commented & provided feedback 4 years ago
karma

Works great! LGTM! =)

User Icon dhgutteridge commented & provided feedback 4 years ago

@jsynacek: Correction, yesterday it gave me an error when I tried to upgrade using Koji downloads, but I didn't know there was a new dependency. (The error messages weren't clear.) When pulling via the updates-testing repo dnf picks up compat-ImageMagick693-libs as a new dependency.

Dependencies resolved.
=======================================================================================================================================
 Package                                   Arch                  Version                          Repository                      Size
=======================================================================================================================================
Upgrading:
 emacs                                     x86_64                1:25.3-1.fc26                    updates-testing                3.1 M
 emacs-common                              x86_64                1:25.3-1.fc26                    updates-testing                 38 M
 emacs-filesystem                          noarch                1:25.3-1.fc26                    updates-testing                 67 k
Installing dependencies:
 compat-ImageMagick693-libs                x86_64                6.9.3.10-1.fc26                  updates-testing                2.1 M

Transaction Summary
=======================================================================================================================================
Install  1 Package
Upgrade  3 Packages

The previous version in updates-testing had increased its ImageMagick dependency requirement to 6.9.9.

User Icon jsynacek commented & provided feedback 4 years ago

@dhgutteridge Does that mean that it works for you now? It looks like it.

User Icon dhgutteridge commented & provided feedback 4 years ago
karma

@jsynacek: Yes, it installs and works fine for me.

BZ#1490649 emacs-25.3 is available

This update has been submitted for stable by bodhi.

4 years ago
User Icon imabug provided feedback 4 years ago
karma
BZ#1490649 emacs-25.3 is available

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
security
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
BZ#1490409 CVE-2017-14482 emacs: command injection flaw within "enriched mode" handling
0
0
BZ#1490410 CVE-2017-14482 emacs: Unsafe enriched mode translations [fedora-all]
0
0
BZ#1490649 emacs-25.3 is available
0
2

Automated Test Results