FEDORA-2017-7f9288e6d7 created by tkrizek 4 years ago for Fedora 25
unpushed
  • Fixes #1456607 ipa-server-certinstall mangles arguments to certutil
  • Fixes #1465472 Error at open session: 0x3 when installling IPA server in F26
  • Fixes #1462155 [python-netifaces] Incompatible change in netmask representation of IPv6 address

  • Fixes #1405814 ipa plugins: ERROR an internal error occured
  • Also fixes these BZs reported for F26, but also present in F25:
    • Fixes #1446744 python2-ipaclient subpackage does not own /usr/lib/python2.7/site-packages/ipaclient/plugins
    • Fixes #1440525 surplus 'the' in output of ipa-adtrust-install

This update has been submitted for testing by tkrizek.

4 years ago

This update has obsoleted freeipa-4.4.4-2.fc25, and has inherited its bugs and notes.

4 years ago
User Icon adamwill commented & provided feedback 4 years ago

So, I have unpushed this because rather than being a separate update, it should be bundled in with softhsm 2.2.0, because softhsm 2.2.0 breaks FreeIPA (that's #1465472 , which this update is listed as fixing). If we have separate updates for softhsm 2.2.0 and freeipa, there's a danger that softhsm 2.2.0 will be pushed stable first, which would mean FreeIPA would be broken in stable until this update was pushed stable.

So I've unpushed this, and edited the softhsm update - https://bodhi.fedoraproject.org/updates/FEDORA-2017-30c570630b - to include a freeipa-4.4.4-4.fc25 build, which is identical to this. (I had to do a rebuild because Bodhi won't let you put the same build in two updates, even if one of them is unpushed).


Please login to add feedback.

Metadata
Type
bugfix
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-2
Stable by Karma
2
Stable by Time
disabled
Dates
submitted
4 years ago
BZ#1405814 ipa plugins: ERROR an internal error occured.
0
0
BZ#1456607 ipa-server-certinstall mangles arguments to certutil
0
0

Automated Test Results