stable

rpm-4.14.0-2.fc27

FEDORA-2017-0d1c2f84a4 created by pmatilai 6 years ago for Fedora 27

Updates rpm to 4.14.0 final release. Most importantly this fixes a nasty regression on signature checking.

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2017-0d1c2f84a4

This update has been submitted for testing by pmatilai.

6 years ago

This update has been pushed to testing.

6 years ago

pmatilai edited this update.

6 years ago
User Icon piotrdrag commented & provided feedback 6 years ago
karma

dnf upgrade worked fine.

User Icon suraia provided feedback 6 years ago
karma
BZ#1500533 DNF installs packages without verifying signatures
User Icon pwalter commented & provided feedback 6 years ago
karma

Works

This update has been submitted for batched by bodhi.

6 years ago

This update has been submitted for stable by bodhi.

6 years ago

This update has been pushed to stable.

6 years ago
User Icon jflory7 commented & provided feedback 6 years ago
karma

This update breaks DNF for me in a Fedora 27 system upgrade. Fedora 25/26 have a newer version of RPM than what Fedora 27 has, and DNF complains about it each time I run.

 Problem 1: cannot install both rpm-libs-4.13.0.2-1.fc26.x86_64 and rpm-libs-4.14.0-2.fc27.x86_64
  - package libdnf-0.11.1-1.fc26.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package rpm-libs-4.14.0-2.fc27.x86_64
  - cannot install the best update candidate for package libdnf-0.11.0-1.fc27.x86_64
 Problem 2: package rpm-libs-4.13.0.2-1.fc26.x86_64 requires rpm = 4.13.0.2-1.fc26, but none of the providers can be installed
  - cannot install both rpm-4.13.0.2-1.fc26.x86_64 and rpm-4.14.0-2.fc27.x86_64
  - package libsolv-0.6.30-1.fc26.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package rpm-4.14.0-2.fc27.x86_64
  - cannot install the best update candidate for package libsolv-0.6.29-2.fc27.x86_64
User Icon pmatilai commented & provided feedback 6 years ago

jflory7, this update is not the cause of your problems, something else is. Possibly libsolv appearing older in f27 than f26, but that'd be some cache/mirror artifact because libsolv-0.6.30-1.fc27 exists for F27. But this is not the place to sort out such problems, and adding negative karma to an update pushed to stable already a month ago will not help either.


Please login to add feedback.

Metadata
Type
bugfix
Severity
high
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
6 years ago
in testing
6 years ago
in stable
6 years ago
modified
6 years ago
BZ#1500533 DNF installs packages without verifying signatures
0
1

Automated Test Results