FEDORA-2016-09abe47360 created by jwakely 5 years ago for Fedora 23
obsolete

The Boost libraries have been updated to fix compilation errors when using boost::asio::use_future.

A bug in the C++ standard library shipped with Fedora caused an incompatibility with part of Boost.Asio. The fix for that bug is not included in Fedora yet, so the Boost packages have been rebuilt to include a workaround taken from the latest Boost release.

This update has been submitted for testing by jwakely.

5 years ago

This update has been pushed to testing.

5 years ago
User Icon filiperosset commented & provided feedback 5 years ago
karma

no regressions noted

User Icon jwakely provided feedback 5 years ago
BZ#1403165 boost::asio::use_future can't be used on Fedora

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

5 years ago
User Icon prabhakarpujeri commented & provided feedback 4 years ago
karma

working as expected


Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
5 years ago
in testing
5 years ago
BZ#1403165 boost::asio::use_future can't be used on Fedora
0
1

Automated Test Results