Comments

134 Comments

Installs fine with rizin on F34.

BZ#1911256 cutter-re-2.0.0 is available
BZ#1929231 F34FailsToInstall: cutter-re

Thanks for testing. The thresholds for oomd have been adjusted, but there also have been some logic fixes in the victim selection, so oomd is indeed worth testing.

given the recent general experiences, wouldn't it be sensible to disable autopush for this and future systemd updates, or at least set the threshold higher than +3?

Yes, that's reasonable. I disabled autokarma now.

Apologies for the bad version. Please test again. The diff is the first five commits on https://github.com/systemd/systemd-stable/commits/v246-stable.

Yeah, it has a patch for that. I forgot to include it in notes though.

BZ#1930652 multiple programs crash in __pkcs15_create_prkey_object when yubikey is inserted

@joechsler: please file a normal bug with logs. This might be the same as one of the existing resolved bugs which are still unsolved.

@akumar99 if you think it mcelog shouldn't fail, please file a new bug. Without any logs it's hard to say what happened.

The tests are failing, e.g. fedora-ci.koji-build.tier0.functional. I have no idea if that means something.

BZ#1875990 cldr-emoji-annotation-38-alpha1 is available
BZ#1882930 cldr-emoji-annotation-38~beta-2fc34 causes broken deps on workstation compose
BZ#1787813 pythran-0.9.7 is available
BZ#1818006 pythran fails to build with Python 3.9: hundreds of test failures
BZ#1878159 python-gast-0.4.0 is available
BZ#1878161 python-beniget-0.3.0 is available
BZ#1880752 Documents preview doesn't work with Nautilus
BZ#1787813 pythran-0.9.7 is available
BZ#1818006 pythran fails to build with Python 3.9: hundreds of test failures
BZ#1878159 python-gast-0.4.0 is available
BZ#1878161 python-beniget-0.3.0 is available

@thebiginfinity: which systemd version did you test?

I added libuv to the update. Without that, it doesn't want to install.

Problem 1: problem with installed package nodejs-1:12.18.3-1.fc32.x86_64 - cannot install the best update candidate for package nodejs-1:12.18.3-1.fc32.x86_64 - nothing provides libuv >= 1:1.39.0 needed by nodejs-1:14.11.0-1.fc33.x86_64

Do I need to do something to get this pushed? It's been waiting for a few days now.

@adamwill This update changes how /etc/resolv.conf is handled, so it's more likely to be symlink, not a static file, and echo'ing stuff to /etc/resolv.conf, i.e. to /run/systemd/resolve/stub-resolv.conf is likely not the right thing [https://openqa.fedoraproject.org/tests/653019/modules/realmd_join_sssd/steps/1/src, line 25]. I assumed the test failed because of this, but maybe it was some other reason...

For the record, there's more change in this update than there really should be.

True, but it's still just cherry-picked patches with clear bugfixes.

@adamw: the test realmd_join_sssd cannot work, I think. It's writing nameservers to /run/systemd/resolve/stub-resolv.conf, expecting something to happen.