Comments

670 Comments

Updating parts of the KDE Plasma desktop to 23.0.4 creates toooo many problems. This whole update needs to re-thought and re-worked.

Thank you for the feedback. I'm sorry this got pushed before those were resolved. Let me address those.

qcoro-qt6 - I was trying to update qt6 at the same time as the rest of the KDE Plasma Desktop. I didn't do my initial testing on ppc64le, and there ended up being issues there. So the qt6 update was delayed. If I am not able to get it out in a day or two, I will rebuild qcoro (or any other qt6 packages affected.

sddm-wayland-generic - Since weston isn't part of KDE Plasma Desktop it got overlooked in the bring over from epel9-next. Here is it's bodhi update https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-5911e42efc

qt-creator - That's unexpected and I'll have to investigate.

Installs and works. Thank you very much.

BZ#2185251 Please branch and build duktape for EPEL 9
BZ#2185253 Please branch and build gerbera for EPEL 9

Installs correctly. Passes all of my tests. Thank you very much for building these.

BZ#2177879 Please branch and build libolm in epel9
BZ#2177881 Please branch and build libqtolm in epel9

LGTM. Thanks for this.

BZ#2173300 kf5-kidletime not built with wayland support to enable automatic display dimming and system sleep

LGTM Thanks

BZ#2152402 Review Request: librist - Library for Reliable Internet Stream Transport (RIST) protocol

LGTM. Thanks

BZ#2156081 appstream-0.16.1 is available

Thank you very much. It needed one other tweak but you got me on the right place. The updated kio-extras is built. It's not yet in -testing, but here is it's bodhi update. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-040ea10be7

Now that I try building it again, I remember why I couldn't build it on epel8. You get errors like these

In file included from /usr/include/OpenEXR/ImfHeader.h:51,
                 from /builddir/build/BUILD/kio-extras-22.04.1/thumbnail/exrcreator.cpp:15:
/usr/include/OpenEXR/ImathVec.h:228:41: error: ISO C++17 does not allow dynamic exception specifications
  228 |     const Vec2 &        normalizeExc () throw (IEX_NAMESPACE::MathExc);
      |                                         ^~~~~

I still think this update can/should go to stable. But I'd appreciate if you opened a bug about kio-extras. I'm betting this is an openexr bug, which is in RHEL 8. It would be good if I had a bug I could point to while working with the maintainer.

kio-extras indeed fell through the cracks. My apologies. The updated kio-extras needs kdsoap to build. Although I built kdsoap for epel9, and thus kio-extras for epel9-next, it never got put on my list of things to do for epel8. I'm working on it right now. A weird docs issue with kdsoap, but I hope to have the updated kio-extras in it's own update today.

I have verified that the older version of these packages (21.08) install and work. There was no real functional updates for these packages in 21.12. I am going to drop this update.

I had to tag in epel8-next packages into the side tag to get these to build. So yes, they were built with libraries that never were built in epel8. The previous version is 21.08 so this isn't really that big of a jump anyway. I'm going to do a few tests to make sure the old ones still install and work, and if the old ones still work, I'll drop this update.

I will update the spec, so that future builds on epel8 use a newer toolset, but I will not hold off this entire release of these packages for it. As kkofler said "What does it matter?"

If you have a legitimate "It doesn't work" or "There is a security issue" then I would certainly hold things off. But simply "it's old" doesn't really carry any weight.

mock-core-configs now installs and things are working correctly for me. Thank You

BZ#2136148 mock-core-configs install fails due to distribution-gpg-keys 1.77 dependency

This was my fault for not looking at the ELN packages that have their own ELN branch. I have untagged this build from ELN.

There is a pull request to fix the installation problem. https://src.fedoraproject.org/rpms/python-breathe/pull-request/12

You are correct. Since this version is broken on anything less than rpkg 1.65, I need to reflect that in the Requires. Otherwise someone might update one without the other. I'll have an updated version soon.

karma

Tested with the new centpkg. I was able to see the errors/failures before the new centpkg, and the fix after. Looks good. Thank you for the fix.

BZ#2061765 Please build fedpkg for EPEL9

The centpkg fix has been built and should be in -testing https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-e1ec8fb19e