Comments

187 Comments
karma

Working for me.

BZ#2041980 Please build kstart for EPEL9

Why not the 4.3?

So quoting from #epel:

it looks like grobisplitter is broken and is including non-default modules into the buildroot.

in fixing the Judy-devel and python38 issue, it looks like non-default modules also got put in the buildroot since the 28th

Indeed:

mock -r centos-stream+epel-8-x86_64  --install globus-common-progs --enablerepo=epel-testing

but so does

mock -r alma+epel-8-x86_64 --install globus-common-progs --enablerepo=epel-testing

also both fail in similar ways as well so bit confused. Builders are even newer ?

So on CentOS stream default I am seeing:

# dnf module list perl
Last metadata expiration check: 0:03:28 ago on Tue 31 May 2022 07:16:41 CEST.
CentOS-8 Stream - Appstream testing [HEAD]
Name                      Stream                           Profiles                                Summary                                                     
perl                      5.24                             common [d], minimal                     Practical Extraction and Report Language                    
perl                      5.26 [d][e]                      common [d], minimal                     Practical Extraction and Report Language                    
perl                      5.30                             common [d], minimal                     Practical Extraction and Report Language                    
perl                      5.32                             common [d], minimal                     Practical Extraction and Report Language  

5.26 as default module.

Seeing the following with CentOS Stream 8

Error: 
 Problem 1: package globus-common-18.13-1.el8.x86_64 requires perl(:MODULE_COMPAT_5.32.1), but none of the providers can be installed
  - cannot install the best update candidate for package globus-common-18.11-1.el8.x86_64
  - package perl-libs-4:5.32.1-471.module_el8.6.0+1070+343f8e3c.x86_64 is filtered out by modular filtering
 Problem 2: package globus-common-progs-18.13-1.el8.x86_64 requires globus-common(x86-64) = 18.13-1.el8, but none of the providers can be installed
  - package globus-common-18.13-1.el8.x86_64 requires perl(:MODULE_COMPAT_5.32.1), but none of the providers can be installed
  - cannot install the best update candidate for package globus-common-progs-18.11-1.el8.x86_64
  - package perl-libs-4:5.32.1-471.module_el8.6.0+1070+343f8e3c.x86_64 is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

trying to understand...

BZ#2037933 Please branch and build R in epel9

Thanks this awscli installs with python3-rsa-4.7.2-1.el8.noarch fine.

BZ#2005231 awscli no longer installable with recent python3-rsa 4.7.2

This package seems to be uninstallable at same time as EPEL awscli package

Package http://linuxsoft.cern.ch/epel/8/Everything/x86_64/Packages/a/awscli-1.18.156-1.el8.noarch.rpm

has a requirement on

python3.6dist(rsa) <= 4.7

and so is uninstallable with this 4.7.2...

I expect the awscli is what actually needs fixing as the requirement is probably to strict?

karma

Indeed only works if you install exactly one package - thanks.

karma

This looks better.

BZ#1933792 ceph crashes with gperftools 2.8

Hi,

dnf install perl-Object-Remote

  • nothing provides perl(Eval::WithLexicals) needed by perl-Object-Remote-0.004001-4.el8.noarch (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I submitted https://bugzilla.redhat.com/show_bug.cgi?id=1906052

Thanks for the update - for sure gfal2 update better in the long term.

Indeed in 7 I see you added an xrootd4-libs and xrootd4-client-libs to satisfy the dependency.

Should 8 be the same?

Hi,

Epel8 with this:

rpm -q gfal2-plugin-xrootd-2.18.1 --requires |grep 'libXrdPosix.s' libXrdPosix.so.2()(64bit)

rpm -q gfal2-plugin-xrootd --requires |grep 'libXrdPosix.s' libXrdPosix.so.2()(64bit)

can no longer be installed.

BZ#1868002 python root, ROOT cannot be imported , import libcppyy2_7. Please check that ROOT has been built for Python 2.7

Imports fine now, thanks.

BZ#1868002 python root, ROOT cannot be imported , import libcppyy2_7. Please check that ROOT has been built for Python 2.7

Yes this package is installable as soon as you have 8.2 available.

Confirm uninstallable.