Comments

416 Comments

but why we not use the current lsb_release ?

I look at Fedora software and try do my best , I see many things unmaintained , and try try fix , with one priority order , lsb was one of them , but after I fix the thing you came up with better solution, why you didn't fix this package 8 year ago ? , why suddenly you remember that remove lsb is the best option ? , lsb is on rhel 8 . Maybe I can send to you list list of things that I'm planning todo , to Neal Gompa fix it

lsb_release -c
Codename:       n/a

lsb_release
LSB Version:    n/a 

lsb-release -s
n/a

while lsb_release from redhat-lsb:

lsb_release
LSB Version:    :core-5.0-amd64:core-5.0-noarch:cxx-5.0-amd64:cxx-5.0-noarch:desktop-5.0-amd64:desktop-5.0-noarch:languages-5.0-amd64:languages-5.0-noarch:printing-5.0-amd64:printing-5.0-noarch

lsb_release -c
ThirtyEight

lsb_release -s
:core-5.0-amd64:core-5.0-noarch:cxx-5.0-amd64:cxx-5.0-noarch:desktop-5.0-amd64:desktop-5.0-noarch:languages-5.0-amd64:languages-5.0-noarch:printing-5.0-amd64:printing-5.0-noarch

"Recommending software that is required to meet LSB compliance is not correct. The entire point of the LSB is to guarantee the presence of specific commands and libraries. Skipping required items is setting us up for missed expectations with users. "

I don't agree with you at all, first after I did a lot of effort on make redhat-lsb-5.0 , it's appear yesterday one minimal lsb_release from a fork which is even less compliant and completely buggy .

second redhat-lsb-5.0 try provide all software that Fedora/Redhat have to LSB compliance , and if we miss some few because they already doesn't exist, we provide the core of the packages that LSB wants . Is the only way, we can do, to provide LSB , and wait for LSB 6.0

karma

lsb_release is already provided by redhat-lsb-core and thkukuk is very buggy

karma

lsb_release is already provided by redhat-lsb-core and thkukuk is very buggy

karma

lsb_release is already provided by redhat-lsb-core and thkukuk is very buggy ,
you should use https://pagure.io/redhat-lsb/commits/main

karma

lsb_release is already provided by redhat-lsb-core and thkukuk is very bugyg

install_initd and remove_initd are available in /usr/lib/lsb/ of redhat-lsb-core

ll /usr/lib/lsb/
total 4
-rwxr-xr-x 1 root root 635 Apr 10  2023 init-functions
lrwxrwxrwx 1 root root  23 Apr 10  2023 install_initd -> ../../../sbin/chkconfig
lrwxrwxrwx 1 root root  23 Apr 10  2023 remove_initd -> ../../../sbin/chkconfig

dnf install infocmp No match for argument: infocmp

infocmp doesn't exist in Fedora 38

reading https://refspecs.linuxfoundation.org/LSB_5.0.0/LSB-Core-generic/LSB-Core-generic/normativerefs.html#STD.SUSV4

The normative references are dated between 1999 and 2009 , for a specification of 2015 , therefore I proppose just the best effort to be compliant

That's just from the table of commands for the core module. Please review that as well as the commands and libraries needed for all the LSB modules.

please send me PR(s), I don't have more time , so do you prefer not have lsb at all in epel9 ? This package is not maintained since 2011 , more or less, and nobody cares about missing commands , the only thing that is needed is lsb_release

yeah it is required by policies , but policies are very outdated and I think the best effort is applicable.

you mean use %bdond macros to conditionalize the whole subpackage ?

For now the goal is bring LSB core and usr/bin/lsb_release to epel9, which will fix many problem, we can add perl packages to epel , spax I even don't know for what is it but seems very old and nobody use it nowadays .

I guess ibxcrypt-compat is only available on epel but not on Centos , that why my test failed ...

They should be required , but if they not exist in repo what we can do ? , packages redhat-lsb-desktop only have 2 empty files, to indicate what version and arch of lsb-desktop are supported [2] and the rest is Requires [1] if we don't have qt4 on el9 , we can't require it. But where I have it, I require it, to be the most accuracy as possible.

LSB 5.0 was released on 2015

[1] rpm -q redhat-lsb-desktop -l --requires /usr/bin/fc-cache /usr/bin/fc-list /usr/bin/fc-match atk(x86-64) cairo(x86-64) freetype(x86-64) gdk-pixbuf2(x86-64) glib2(x86-64) gtk2(x86-64) libICE(x86-64) libSM(x86-64) libX11(x86-64) libXext(x86-64) libXft(x86-64) libXi(x86-64) libXrender(x86-64) libXt(x86-64) libXtst(x86-64) libjpeg-turbo(x86-64) libpng(x86-64) libpng12.so.0()(64bit) libxml2(x86-64) mesa-libGL(x86-64) mesa-libGLU(x86-64) pango(x86-64) qt(x86-64) qt-x11(x86-64) redhat-lsb-core(x86-64) = 5.0-2.20231006git4d6a9e05.fc38 rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(PayloadIsZstd) <= 5.4.18-1 xdg-utils

[2] /etc/lsb-release.d/desktop-5.0-amd64 /etc/lsb-release.d/desktop-5.0-noarch

This update has been unpushed.

can you check if contained 1.7.0 from https://copr.fedorainfracloud.org/coprs/sergiomb/docker2/builds/ works for you ?

we have a lot of stuff to update ...