Comments

444 Comments

Installation works (pulls in golang-x-sys-devel) on c9s. Uninstallation works fine too.

BZ#2095050 golang-x-sys: please provide epel9 package
BZ#2137748 Review Request: libipuz - Library for parsing .ipuz puzzle files
BZ#2137749 Review Request: crosswords - Solve crossword puzzles

Tested, works fine

BZ#2137748 Review Request: libipuz - Library for parsing .ipuz puzzle files
BZ#2137749 Review Request: crosswords - Solve crossword puzzles

Previous kronosnet-epel installs fine if epel-testing is disabled, so with the bumped release it should be fine. Tried installing doxygen2man and it pulls in libqb so all looks fine.

This is because epel-testing has -3.el9 while epel-next-testing has -2.el9.next - you'll need to keep them in sync

Not currently installable

Error: 
 Problem 1: cannot install the best candidate for the job
  - nothing provides libknet1(x86-64) = 1.22-4.el9_0 needed by kronosnet-tests-1.24-3.el9.x86_64
 Problem 2: package libknet1-plugins-all-1.24-3.el9.x86_64 requires libknet1-compress-plugins-all(x86-64) = 1.24-3.el9, but none of the providers can be installed
  - package libknet1-compress-plugins-all-1.24-3.el9.x86_64 requires libknet1-compress-zstd-plugin(x86-64) = 1.24-3.el9, but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides libknet1(x86-64) = 1.22-4.el9_0 needed by libknet1-compress-zstd-plugin-1.24-3.el9.x86_64
karma

Installs fine

$ sudo dnf --refresh --enablerepo=epel-testing install kronosnet-tests libknet1-plugins-all pulls in 22 packages on my Alma 9 container, and removing them removes the same 22 packages cleanly.

This broke Emacs; _gst_meta_tag_memory_reference is undefined. Rolling back gstreamer1-plugins-base to the 1.20.3-2.fc37 in updates fixes the issue

rust-update-set on  main [?] 
✦ ❯ emacs: symbol lookup error: /lib64/libgstvideo-1.0.so.0: undefined symbol: _gst_meta_tag_memory_reference

fish: Job 1, 'emacs rust-update-set/dependenc…' has ended

rust-update-set on  main [?] 
❯ rpm -qf /usr/lib64/libgstvideo-1.0.so.0
gstreamer1-plugins-base-1.20.4-1.fc37.x86_64

rust-update-set on  main [?] 
❯ sudo dnf distro-sync gstreamer1-plugins-base
[sudo] password for michel: 
Last metadata expiration check: 0:23:24 ago on Mon 31 Oct 2022 10:21:16 AM CDT.
Dependencies resolved.
===========================================================================================================================
 Package                                 Architecture           Version                       Repository              Size
===========================================================================================================================
Downgrading:
 gstreamer1-plugins-base                 x86_64                 1.20.3-2.fc37                 fedora                 2.2 M

Transaction Summary
===========================================================================================================================
Downgrade  1 Package

Total download size: 2.2 M
Is this ok [y/N]: y
Downloading Packages:
gstreamer1-plugins-base-1.20.3-2.fc37.x86_64.rpm                                           692 kB/s | 2.2 MB     00:03    
---------------------------------------------------------------------------------------------------------------------------
Total                                                                                      645 kB/s | 2.2 MB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                   1/1 
  Downgrading      : gstreamer1-plugins-base-1.20.3-2.fc37.x86_64                                                      1/2 
  Cleanup          : gstreamer1-plugins-base-1.20.4-1.fc37.x86_64                                                      2/2 
  Running scriptlet: gstreamer1-plugins-base-1.20.4-1.fc37.x86_64                                                      2/2 
  Verifying        : gstreamer1-plugins-base-1.20.3-2.fc37.x86_64                                                      1/2 
  Verifying        : gstreamer1-plugins-base-1.20.4-1.fc37.x86_64                                                      2/2 

Downgraded:
  gstreamer1-plugins-base-1.20.3-2.fc37.x86_64                                                                             

Complete!
^[[A^[[A⏎                                                                                                                  
rust-update-set on  main [?] took 53s 
❯ emacs rust-update-set/dependency_check.py &

rust-update-set on  main [?] 
BZ#2134899 Review Request: packetdrill - Quick, precise tests for entire TCP/UDP/IPv4/IPv6 network stacks
BZ#2134899 Review Request: packetdrill - Quick, precise tests for entire TCP/UDP/IPv4/IPv6 network stacks

Works great, thanks!

⬢ [centos:stream8] ❯ sudo dnf install ./corosync*
Last metadata expiration check: 21:24:42 ago on Thu 13 Oct 2022 01:16:04 PM CDT.
Dependencies resolved.
================================================================================
 Package                      Arch     Version             Repository      Size
================================================================================
Installing:
 corosync                     x86_64   3.1.5-0.2.el8.2     @commandline   278 k
 corosynclib-devel            x86_64   3.1.5-0.2.el8.2     @commandline   187 k
Installing dependencies:
 corosynclib                  x86_64   3.1.5-2.el8         appstream       69 k
 libknet1                     x86_64   1.24-2.el8          powertools      81 k
 libknet1-crypto-nss-plugin   x86_64   1.24-4.el8.next     epel-next       20 k
 libnozzle1                   x86_64   1.24-4.el8.next     epel-next       32 k
 libqb                        x86_64   1.0.3-12.el8        baseos         113 k
 libqb-devel                  x86_64   1.0.3-12.el8        baseos         106 k
 libxslt                      x86_64   1.1.32-6.el8        baseos         250 k
 net-snmp-libs                x86_64   1:5.8-25.el8        baseos         827 k
 nspr                         x86_64   4.34.0-3.el8        appstream      143 k
 nss                          x86_64   3.79.0-10.el8       appstream      747 k
 nss-softokn                  x86_64   3.79.0-10.el8       appstream      1.2 M
 nss-softokn-freebl           x86_64   3.79.0-10.el8       appstream      398 k
 nss-sysinit                  x86_64   3.79.0-10.el8       appstream       74 k
 nss-util                     x86_64   3.79.0-10.el8       appstream      139 k

Transaction Summary
================================================================================
Install  16 Packages

Total size: 4.6 M
Total download size: 4.1 M
Installed size: 12 M

The version pin is too tight I think, maybe drop the release? Otherwise, if you really want to pin this to require exactly that corosynclib release, you forgot to add %{?dist}

❯ sudo dnf info corosynclib
Last metadata expiration check: 3:50:20 ago on Thu 13 Oct 2022 01:16:04 PM CDT.
Available Packages
Name         : corosynclib
Version      : 3.1.5
Release      : 2.el8
Architecture : i686
Size         : 72 k
Source       : corosync-3.1.5-2.el8.src.rpm
Repository   : appstream
Summary      : The Corosync Cluster Engine Libraries
URL          : http://corosync.github.io/corosync/
License      : BSD
Description  : This package contains corosync libraries.

Name         : corosynclib
Version      : 3.1.5
Release      : 2.el8
Architecture : x86_64
Size         : 69 k
Source       : corosync-3.1.5-2.el8.src.rpm
Repository   : appstream
Summary      : The Corosync Cluster Engine Libraries
URL          : http://corosync.github.io/corosync/
License      : BSD

This does not seem to be installable

❯ sudo dnf install ./corosync-3.1.5-0.2.el8.1.x86_64.rpm 
Last metadata expiration check: 3:47:57 ago on Thu 13 Oct 2022 01:16:04 PM CDT.
Error: 
 Problem: conflicting requests
  - nothing provides corosynclib(x86-64) = 3.1.5-2 needed by corosync-3.1.5-0.2.el8.1.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use 
BZ#2124260 Cannot build kronosnet-epel for epel9 until libqb-devel is available
BZ#2124260 Cannot build kronosnet-epel for epel9 until libqb-devel is available
BZ#2134160 Main package should pull in pam_duo to avoid lockout
BZ#2134160 Main package should pull in pam_duo to avoid lockout
BZ#2134160 Main package should pull in pam_duo to avoid lockout