Comments

50 Comments

This update has been unpushed.

This update has been unpushed.

This update has been unpushed.

This update has been unpushed.

new bugfix version was just released today

new bugfix version was just released today

new bugfix version was just released today

new bugfix version was just released today

decompile to json is not working properly

decompile to json is not working properly

BZ#1948322 radare2-5.2.0 is available

Tested on F33, and I extrapolate the results to F34.

On f33 both rizin and cutter-re seems to work fine (took the packages directly from koji). Package is installable, checked also the application launcher and the record for gnome software.

BZ#1911256 cutter-re-2.0.0 is available
BZ#1929231 F34FailsToInstall: cutter-re

For testing took packaged directly from koji. both rizin and cutter-re worked as expected

BZ#1911256 cutter-re-2.0.0 is available
karma

Works without cutter, but breaks dependencies if installed:

$ dnf update radare2 cutter-re --enablerepo=updates-testing --allowerasing Last metadata expiration check: 0:32:20 ago on 2021-02-28T01:39:28 CET. Dependencies resolved.

Problem: cannot install the best update candidate for package cutter-re-1.11.0-2.fc33.x86_64 - problem with installed package cutter-re-1.11.0-2.fc33.x86_64 - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_anal.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_asm.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_bin.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_bp.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_config.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_cons.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_core.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_crypto.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_debug.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_egg.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_flag.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_fs.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_hash.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_io.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_parse.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_reg.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_search.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_syscall.so.4.5.0()(64bit), but none of the providers can be installed - package cutter-re-1.11.0-2.fc33.x86_64 requires libr_util.so.4.5.0()(64bit), but none of the providers can be installed - cannot install the best update candidate for package radare2-4.5.0-2.fc33.1.x86_64 - cannot install both radare2-5.1.1-1.fc33.x86_64 and radare2-4.5.0-2.fc33.1.x86_64 - cannot install both radare2-4.5.0-2.fc33.1.x86_64 and radare2-5.1.1-1.fc33.x86_64 - cannot install both radare2-4.5.0-1.fc33.1.x86_64 and radare2-5.1.1-1.fc33.x86_64 ====================================================================================================================================== Package Architecture Version Repository Size

====================================================================================================================================== Skipping packages with conflicts: (add '--best' to command line to force their upgrade): radare2 x86_64 4.5.0-1.fc33.1 fedora 4.0 M radare2 x86_64 5.1.1-1.fc33 updates-testing 4.1 M

Transaction Summary ====================================================================================================================================== Skip 2 Packages

Nothing to do. Complete!

there is issue with pcapy in other builds

This update has been unpushed.

This update has been unpushed.