Comments

367 Comments
karma

Indeed breaks ABI for both packages that depend on re2 according to repoquery: perl-re-engine-RE2 and qt5-qtwebengine

ldd -r /usr/lib64/perl5/vendor_perl/auto/re/engine/RE2/RE2.so undefined symbol: _ZNK3re23RE25MatchERKNS_11StringPieceEiiNS0_6AnchorEPS1_i (/usr/lib64/perl5/vendor_perl/auto/re/engine/RE2/RE2.so) undefined symbol: _ZNK3re23RE223NumberOfCapturingGroupsEv (/usr/lib64/perl5/vendor_perl/auto/re/engine/RE2/RE2.so)

the qtwebengine one already documented in previous comment. I'll comment in bug #1672014

it's ok, I'll get that one submitted separately, rather than resetting this big batch again.

Taking liberty to queue for stable, holler if there are any objections

Can this go stable soon? I ask because pyotherside needs to be included in recently-submitted Qt 5.12.4 update too, https://bodhi.fedoraproject.org/updates/FEDORA-2019-64c013e73f Feel free to reach out if you have any questions or concerns. If I include a newer pyotherside build in the Qt update, it will obsolete this one. Let me know how you'd prefer to proceed.

I added an explicit Conflicts: tag to new gstreamer1-plugins-ugly-free-1.16.0-3.fc30 build, if you want to pull that in here.

Otherwise, good +1

BZ#1709470 Enable mpeg2dec plugin in ugly-free

I added an explicit Conflicts: tag to new gstreamer1-plugins-ugly-free-1.14.4-2.fc29 build, if you want to pull that in here.

Otherwise, good +1

BZ#1707976 Review Request: libmpeg2 - MPEG-2 decoder
BZ#1709470 Enable mpeg2dec plugin in ugly-free

I documented the CELT issue in bug https://bugzilla.redhat.com/show_bug.cgi?id=1711435 , and subsequently found the root cause (typo wrt DEFINES+="PLUGIN_PATH=%{_libdir}/%{name}" not getting used). New/fixed builds on the way.

Please file a bug for the new celt issue

karma

I appears all qt5-qtwebengine using apps crash now, definitely bad :(

Patch works as advertised, starts ok now

BZ#1670396 KSieve fails to start

OK, I'll pull in qt5ct-0.38-2.fc30 when the build finishes

Cantor and kalgebra did not require rebuilding in my own testing (only analitza)

This update has been unpushed.

Good point, unpushing.

I'll push (pun intended) harder in the aforementioned bug to get selinux policy updated to remediate this.

sddm issue is selinux-related, and is being tracked in bug https://bugzilla.redhat.com/show_bug.cgi?id=1686675
This update will not go stable until that is resolved.

This update has been unpushed.

It's not clear this is even needed on f30, referenced bug appears to be rawhide/f31+ only. unpushing

same bustage here too :(