Comments

134 Comments
--- Ocsinventory-Unix-Agent-2.6.0.orig/lib/Ocsinventory/Agent/Network.pm        2018-07-28 18:27:52.000000000 +0300
+++ Ocsinventory-Unix-Agent-2.6.0/lib/Ocsinventory/Agent/Network.pm     2019-07-02 09:31:55.271132600 +0300
@@ -49,13 +49,11 @@
     my $version = 'OCS-NG_unified_unix_agent_v';
     $version .= exists ($self->{config}->{VERSION})?$self->{config}->{VERSION}:'';
     $self->{ua}->agent($version);
-    $self->{config}->{user}.",".
-    my $password = $self->{config}->{password}."";
     $self->{ua}->credentials(
         $uaserver, # server:port, port is needed
         $self->{config}->{realm},
         $self->{config}->{user},
-        $password,
+        $self->{config}->{password},
     );

     #Setting SSL configuration depending on LWP version

I use the following patch for this error: --- Ocsinventory-Unix-Agent-2.6.0.orig/lib/Ocsinventory/Agent/Network.pm 2018-07-28 18:27:52.000000000 +0300 +++ Ocsinventory-Unix-Agent-2.6.0/lib/Ocsinventory/Agent/Network.pm 2019-07-02 09:31:55.271132600 +0300 @@ -49,13 +49,11 @@ my $version = 'OCS-NG_unified_unix_agent_v'; $version .= exists ($self->{config}->{VERSION})?$self->{config}->{VERSION}:''; $self->{ua}->agent($version); - $self->{config}->{user}.",". - my $password = $self->{config}->{password}.""; $self->{ua}->credentials( $uaserver, # server:port, port is needed $self->{config}->{realm}, $self->{config}->{user}, - $password, + $self->{config}->{password}, );

 #Setting SSL configuration depending on LWP version

After systemctl enable --now ocsinventory-agent in /var/log/ocsinventory-agent/ocsinventory-agent.log:

[Wed 27 Nov 2019 12:43:21 AM EET] Running ocsinventory-agent --wait 100 --lazy --nolocal --server=... Failed to load Ocsinventory::Agent, syntax error at /usr/share/perl5/vendor_perl/Ocsinventory/Agent/Network.pm line 56, near "};" Compilation failed in require at /usr/share/perl5/vendor_perl/Ocsinventory/Agent.pm line 33. BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Ocsinventory/Agent.pm line 33. Compilation failed in require at (eval 1) line 1. BEGIN failed--compilation aborted at (eval 1) line 1.

BZ#1768050 Adjust to ansible packaging changes

Problem 1: package python3-ansible-lint-4.1.0-2.fc31.noarch requires ansible-python3, but none of the providers can be installed - cannot install both ansible-2.8.6-1.fc31.noarch and ansible-2.8.5-1.fc31.noarch - cannot install both ansible-2.8.5-1.fc31.noarch and ansible-2.8.6-1.fc31.noarch - cannot install the best update candidate for package python3-ansible-lint-4.1.0-2.fc31.noarch - cannot install the best update candidate for package ansible-2.8.5-1.fc31.noarch

karma

The same crash as reported.

BZ#1674143 youtube-dl missing python34-setuptools dependency
BZ#1718508 youtube-dl should Require setuptools
BZ#1724750 youtube-dl-2019.07.12 is available
BZ#1734541 WARNING: Unable to extract video title
BZ#1670645 youtube-dl-2019.04.24 is available
BZ#1674143 youtube-dl missing python34-setuptools dependency
BZ#1702595 youtube-dl needs to be updated otherwise it cannot be used with Youtube anymore
BZ#1718508 youtube-dl should Require setuptools
BZ#1722763 youtube-dl needs an update to version 8.6.2019, as it throws 403 errors
BZ#1722918 youtube-dl-2019.06.21 is available
BZ#1722934 ERROR: Signature extraction failed
BZ#1723012 regex error when downloading from youtube
BZ#1724750 youtube-dl-2019.07.12 is available
BZ#1734541 WARNING: Unable to extract video title
BZ#1670645 youtube-dl-2019.04.24 is available
BZ#1674143 youtube-dl missing python34-setuptools dependency
BZ#1702595 youtube-dl needs to be updated otherwise it cannot be used with Youtube anymore
BZ#1718508 youtube-dl should Require setuptools
BZ#1722763 youtube-dl needs an update to version 8.6.2019, as it throws 403 errors
BZ#1722918 youtube-dl-2019.06.21 is available
BZ#1722934 ERROR: Signature extraction failed
BZ#1723012 regex error when downloading from youtube
BZ#1724750 youtube-dl-2019.07.12 is available
BZ#1734541 WARNING: Unable to extract video title

package clementine-1.3.1-36.20181130gitd260c8b.fc30.x86_64 requires libprojectM.so.2()(64bit), but none of the providers can be installed

karma

Problem 1: cannot install the best update candidate for package electrum-3.2.3-1.fc29.noarch - nothing provides python3.7dist(qdarkstyle) < 3.0 needed by electrum-3.2.4-1.fc29.noarch - nothing provides python3.7dist(typing) >= 3.0.0 needed by electrum-3.2.4-1.fc29.noarch

Text is rendered correctly after browser restart.

BZ#1628812 typo in 66-google-noto-mono.conf
BZ#1636511 update Google Noto to 2017-09-19 release

Some letters are rendered incorrectly, see bug 1636511 for example.

BZ#1636511 update Google Noto to 2017-09-19 release
karma

Problem: package glibc-headers-2.28-17.fc29.i686 requires glibc = 2.28-17.fc29, but none of the providers can be installed - cannot install both glibc-2.28-20.fc29.i686 and glibc-2.28-17.fc29.i686 - cannot install both glibc-2.28-17.fc29.i686 and glibc-2.28-20.fc29.i686 - cannot install both glibc-2.28-20.fc29.x86_64 and glibc-2.28-17.fc29.x86_64 - cannot install both glibc-2.28-17.fc29.x86_64 and glibc-2.28-20.fc29.x86_64 - cannot install the best update candidate for package glibc-2.28-17.fc29.i686 - cannot install the best update candidate for package glibc-2.28-17.fc29.x86_64

BZ#1629491 SpamAssassin 3.4.2 released with CVE disclosure