Comments

54 Comments

The mscore change completely removes dependencies on qt5-qtquickcontrols and qt5-qtquickcontrols2, rather than just removing the version from the dependency. The mscore package really does need those. Can you put the dependencies back, please, just without the version requirement?

I am giving this negative karma for exactly the same reasons as for the F36 update. See https://bodhi.fedoraproject.org/updates/FEDORA-2022-5265e7e46b for details.

I deliberately did not build antlr4-project 4.10.1 for stable releases for a few reasons.

First, the parsers generated by ANTLR 4.10 are incompatible with the runtimes from ANTLR < 4.10. This makes such an update disruptive, which I think violates the spirit of https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#philosophy.

Second, due to the first point, all packages that use ANTLR runtimes in Fedora would have to be rebuilt, and would have to actually run the antlr tool in %build to generate parsers. That work has been done in Rawhide. As far as I know, it has not been done (at least not completely) in F35 and F36.

Third, one of the packages from the second point is coq. Rebuilding coq requires rebuilding every package that depends on coq. The reason for this is that coq generates a cryptographic hash during the build, which is used to prove that dependent libraries of proofs were proved with the same version of coq used to check them later. (I'm fibbing a little here, but that is close enough for this discussion.) In any case, a coq rebuild requires rebuilds, in the correct order, of flocq, ocaml-menhir, zenon, gappalib-coq, why3, and frama-c.

Fourth, I have deliberately held off on updating coq from version 8.13 in F35, because that also is a disruptive change, so it would be wrong to simply do a git merge with rawhide. Commits would have to be carefully chosen and cherry picked back to F35 to avoid breaking things.

Fifth, this update did such a git merge, and therefore picked up other changes that were intended only for Rawhide, not for stable. For example, the exclusion of i686 is one such change.

Why do you want this update? If it's a good reason, I will help you, but it's a lot of trouble and bother, with potential disruption to 3rd parties, which is why I hadn't done it.

karma

This affects Rawhide, too, where the iml package build, for example, now fails like this:

make[2]: Entering directory '/builddir/build/BUILD/iml-1.0.5/tests'
FAIL: test-smallentry
FAIL: test-largeentry
===================
2 of 2 tests failed
===================
make[2]: Leaving directory '/builddir/build/BUILD/iml-1.0.5/tests'
?[1;2;31mflexiblas dlopen: /usr/lib64/flexiblas//libflexiblas_fallback_lapack.so: undefined symbol: _gfortran_transfer_character_write
?[1;2;31mflexiblas  Failed to load the LAPACK fallback library.  Abort!
?[1;2;31mflexiblas dlopen: /usr/lib64/flexiblas//libflexiblas_fallback_lapack.so: undefined symbol: _gfortran_transfer_character_write
?[1;2;31mflexiblas  Failed to load the LAPACK fallback library.  Abort!
make[2]: *** [Makefile:422: check-TESTS] Error 1
make[1]: *** [Makefile:545: check-am] Error 2
make: *** [Makefile:339: check-recursive] Error 1

This update has been unpushed.

The issue has been reported upstream. I've added a patch to work around the problem. Upstream may ultimately choose another solution, but this one works.

Oh, okay. Let me undo that and try again.

It looks like you got a good build in koji, too. So ... there's nothing to do here, then?

Huh. A local mock build succeeded: mock -r fedora-rawhide-i386 --rebuild cppcheck-2.7.3-2.fc37.src.rpm. I verified that z3 4.8.15-1 was pulled into the buildroot. I'm not sure what is going on here.

The way koji works, it is not possible to build an F35 with F36 packages in the buildroot. The issue is that the upstream package has this in PKG-INFO:

Requires-Dist: importlib-metadata (>=4.6.3,<5.0.0)

I have tried patching that to 4.6.3, and the package seems to install and function properly. I will do a new build (of version 0.3.2) with that change.

User Icon jjames commented & provided feedback on arb-2.20.0-2.fc34 a year ago

Mea culpa. I thought flint 2.7.1 had gone stable in F34 before I built, but it hadn't quite yet. This build should fix the issue.

The crash you are experiencing has nothing to do with this update, which just updates the sound font. I will follow up with you on bugzilla about the crash.

The problem noted above is probably the Wayland incompatibility that has been noted earlier. I don't think it has anything to do with the changes in this update, so I'm going to push it stable. Suggestions on how to figure out the Wayland issue are welcome.

@lruzicka, did the previous Fedora build behave differently, or is this the only version you have tried?

The Flatpak version doesn't have Qt 5.15. I think it is built with Qt 5.9.

Oops. Let's try that again.

Fixes the man page.

BZ#1878383 xsltproc man page mangled

Aaaaah. Much better!

BZ#1878383 xsltproc man page mangled

This update has been unpushed.

This update has been unpushed.

This update has been unpushed.