Comments

23 Comments

hotspot currently depends on libkddockwidgets.so.1.6, it needs to be rebuilt

karma

I have mostly the same issue here : - numbers are very small and blurry, spacing is too small (so characters overlap) - most text is a little different (not sure if it's Noto Color Emoji, my default sans-serif family font (DejaVuSans) is still loaded) - some text, like in titlebar and taskbar has lots of spacing

Even if not used in KDE font configuration, generic families should work, as they can be used, either explicitly or probably through fontconfig aliases (if a program requests Arial for example). So the emoji fallback must only be used for emoji characters.

zeal needs to be rebuilt again (this time not for the private API, but for Qt 6.5.1 => 6.5.2) :

 Problem 1: package zeal-0.6.2-3.20230618.1cfa7c6.fc38.x86_64 from @System requires qt6-qtbase(x86-64) = 6.5.1, but none of the providers can be installed
  - cannot install both qt6-qtbase-6.5.2-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.5.1-2.fc38.x86_64 from @System
  - cannot install both qt6-qtbase-6.5.2-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.5.1-2.fc38.x86_64 from updates
  - cannot install the best update candidate for package zeal-0.6.2-3.20230618.1cfa7c6.fc38.x86_64
  - cannot install the best update candidate for package qt6-qtbase-6.5.1-2.fc38.x86_64
 Problem 2: problem with installed package zeal-0.6.2-3.20230618.1cfa7c6.fc38.x86_64
  - package zeal-0.6.2-3.20230618.1cfa7c6.fc38.x86_64 from @System requires qt6-qtbase(x86-64) = 6.5.1, but none of the providers can be installed
  - package zeal-0.6.2-3.20230618.1cfa7c6.fc38.x86_64 from updates requires qt6-qtbase(x86-64) = 6.5.1, but none of the providers can be installed
  - cannot install both qt6-qtbase-6.5.2-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.5.1-2.fc38.x86_64 from @System
  - cannot install both qt6-qtbase-6.5.2-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.5.1-2.fc38.x86_64 from updates
  - package qt6-qt5compat-6.5.2-1.fc38.x86_64 from updates-testing requires qt6-qtbase(x86-64) = 6.5.2, but none of the providers can be installed
  - cannot install the best update candidate for package qt6-qt5compat-6.5.1-3.fc38.x86_64

It seems zeal needs a rebuild :

 Problem 1: package zeal-0.6.2-2.20230618.1cfa7c6.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt6-qtbase-gui-6.5.1-2.fc38.x86_64 from updates and qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @System
  - cannot install the best update candidate for package zeal-0.6.2-2.20230618.1cfa7c6.fc38.x86_64
  - cannot install the best update candidate for package qt6-qtbase-gui-6.5.1-1.fc38.x86_64
 Problem 2: problem with installed package zeal-0.6.2-2.20230618.1cfa7c6.fc38.x86_64
  - package zeal-0.6.2-2.20230618.1cfa7c6.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed
  - package zeal-0.6.2-2.20230618.1cfa7c6.fc38.x86_64 from updates requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt6-qtbase-gui-6.5.1-2.fc38.x86_64 from updates and qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @System
  - package qt6-qt5compat-6.5.1-3.fc38.x86_64 from updates requires libQt6Gui.so.6(Qt_6.5_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package qt6-qt5compat-6.5.1-1.fc38.x86_64
karma

openconnect now works fine with the rebuilt xmlsec1

BZ#2136800 openconnect fails due to missing symbol xmlIOFTPRead
karma

It breaks openconnect, see https://bugzilla.redhat.com/show_bug.cgi?id=2136800. Either the FTP support needs to be enabled to keep the symbols, or xmlsec1 (at least) need to be rebuilt.

karma

Failed to update too.

This package was built with llvm-13.0.0~rc1-1.fc35.x86_64 , it needs at least 13.0.0-2 for the soname change (https://src.fedoraproject.org/rpms/llvm/c/a26e75dfb6b6c5e70f45da99769d7df320f58980?branch=f35).

karma

It switches to nftables backend, which breaks NetworkManager connection sharing, see https://bugzilla.redhat.com/show_bug.cgi?id=1785494#c4

karma

Works, but you have to manully install python3-qt5-webkit or python3-qt5-webengine in order to display the Help->Shortcuts in the application (else it opens in a web browser).

BZ#1705023 git-cola should require Qt5 instead of Qt4
BZ#1241555 fakechroot isn't multilib

This build adds a patch for #1660279, but why were the other ones included ? At least #1553086 isn't fixed for example.

This build adds a patch for #1660279, but why were the other ones included ? At least #1553086 isn't fixed for example.

This build adds a patch for #1660279, but why were the other ones included ? At least #1553086 isn't fixed for example.

karma

No compat packages were produced, but libxcrypt-static requires libxcrypt-compat-devel.

User Icon hwti commented & provided feedback on glibc-2.26-15.fc27 6 years ago

It seems the x86_64 fedora-update-testing doesn't have libcrypt-nss-2.26-14.fc27.i686, unlike the x86_64 fedora repo which has libcrypt-nss-2.26-8.fc27.i686.

However, it has both libcrypt-2.26-14.fc27, so the update worked for we with --allowerasing (it removed both libcrypt-nss and switched to libcrypt).

User Icon hwti commented & provided feedback on glibc-2.25-12.fc26 6 years ago

Sorry, wrong update. f26 doesn't seem to have the issue, but @nucleo's comment suggested an issue similar to f27.

User Icon hwti commented & provided feedback on glibc-2.25-12.fc26 6 years ago

It seems the x86_64 fedora-update-testing doesn't have libcrypt-nss-2.26-14.fc27.i686, unlike the x86_64 fedora repo which has libcrypt-nss-2.26-8.fc27.i686. However, it has both libcrypt-2.26-14.fc27, so the update worked for we with --allowerasing (it removed both libcrypt-nss and switched to libcrypt).

BZ#1322393 ktp-text-ui window is empty

I don't know why the update triggers the issue, but opening kickoff and typing a few characters to search something crashes plasmashell in mesa code (callstack similar to https://bugs.kde.org/show_bug.cgi?id=353681). Reverting to 5.4.2-4 avoids the issue.

When connecting, it asks for the password after a few seconds. If I don't check the "save password" checkbox it works, else ktp-auth-handler crashes.

After deleting the account, adding it back didn't work (like https://bugs.kde.org/show_bug.cgi?id=351375).

Adding telepathy-accounts-signon (built with the spec under review) fixed my issues, it seems to be mandatory for ktp >= 15.08.