Comments

328 Comments

Installation works now.

BZ#2050852 dehydrated: fails to install from epel9

I was able to use this to download sources from the lookaside cache for a dist-git repo I had already cloned. Works as expected.

I don't think we should push an .el9.next build into regular epel9 due to the confusion it may cause. We just need an epel9 branch and then we can do a regular epel9 build. I've asked for this in #2007051.

BZ#2007051 fedpkg-minimal: branch for epel9-next

Installed from koji and interacted with OpenSSL.crypto. Everything I tried works as expected.

BZ#2008709 pyOpenSSL-21.0.0 is available

Does this major version update comply with the EPEL updates policy? If not you must follow the process in the incompatible updates policy.

Does this major version update comply with the EPEL updates policy? If not you must follow the process in the incompatible updates policy.

karma
Error: Package: spacefm-Faenza-1.0.5-2.el7.noarch (epel-testing)
           Requires: faenza-icon-theme
Error: Package: python2-zanata-client-1.5.2-1.el7.noarch (epel-testing)
           Requires: python2-lxml
Error: Package: python2-cotyledon-tests-1.2.7-2.el7.noarch (epel-testing)
           Requires: python-oslotest
Error: Package: python2-abclient-0.2.3-4.el7.noarch (epel-testing)
           Requires: python-oslo-log
Error: Package: python2-abclient-0.2.3-4.el7.noarch (epel-testing)
           Requires: python-oslo-utils
Error: Package: golang-github-spf13-viper-devel-0-0.7.git1699063.el7.noarch (epel-testing)
           Requires: golang(github.com/spf13/jwalterweatherman)
Error: Package: golang-github-spf13-viper-devel-0-0.7.git1699063.el7.noarch (epel-testing)
           Requires: golang(github.com/pelletier/go-toml)
Error: Package: golang-github-hashicorp-go-sockaddr-devel-0-0.2.gitaf174a6.el7.noarch (epel-testing)
           Requires: golang(github.com/ryanuber/columnize
karma
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides slop needed by screenkey-1.4-2.el8.noarch
BZ#1914246 python-uvicorn fails to build with Python 3.10 due to problem in python-websockets: the *loop* parameter was removed from Lock()
BZ#1966531 python-uvicorn-0.15.0 is available
BZ#1968971 F35FailsToInstall: python3-falcon
BZ#1969166 F35FailsToInstall: python3-uvicorn+standard, python3-uvicorn. The build hangs in %check
BZ#1987895 python-uvicorn: FTBFS in Fedora rawhide/f35
BZ#1988073 python-falcon: FTBFS in Fedora rawhide/f35
BZ#2002542 python-websockets-10.0 is available

python3-{falcon,httptools,uvicorn,websockets} all install fine, but python3-pytest-sanic does not.

Error: 
 Problem: conflicting requests
  - nothing provides (python3.10dist(websockets) < 9 with python3.10dist(websockets) >= 8.1) needed by python3-pytest-sanic-1.7.0-3.fc35.noarch
  - nothing provides python3.10dist(httpx) >= 0.18.1 needed by python3-pytest-sanic-1.8.1-2.fc35.noarch
BZ#1914246 python-uvicorn fails to build with Python 3.10 due to problem in python-websockets: the *loop* parameter was removed from Lock()
BZ#1966531 python-uvicorn-0.15.0 is available
BZ#1968971 F35FailsToInstall: python3-falcon
BZ#1969166 F35FailsToInstall: python3-uvicorn+standard, python3-uvicorn. The build hangs in %check
BZ#1985599 F35FailsToInstall: python3-pytest-sanic
BZ#1987895 python-uvicorn: FTBFS in Fedora rawhide/f35
BZ#1988073 python-falcon: FTBFS in Fedora rawhide/f35
BZ#2002542 python-websockets-10.0 is available
Error: 
 Problem: package compose-utils-0.1.45-2.el8.noarch requires python3-compose-utils = 0.1.45-2.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides python3-productmd >= 1.33 needed by python3-compose-utils-0.1.45-2.el8.noarch
  - nothing provides python3.6dist(productmd) >= 1.33 needed by python3-compose-utils-0.1.45-2.el8.noarch