Comments

347 Comments

This update has been unpushed.

This update has been unpushed.

Thanks. Unpushing until I've packaged socks.

This update has been unpushed.

This update has been unpushed.

Also cannot be installed because it needs specific versions of numpy and h5py. Negative karma to prevent pushing to users.

BZ#1868037 python-hdmf-2.4.0 is available
BZ#1868037 python-hdmf-2.4.0 is available

Cannot currently be installed, please unpush both F33 and F34 updates :(

Problem: cannot install the best candidate for the job - nothing provides (python3.9dist(h5py) < 3 with python3.9dist(h5py) >= 2.9) needed by python3-hdmf-2.4.0-1.fc34.noarch - nothing provides (python3.9dist(numpy) < 1.19.4 with python3.9dist(numpy) >= 1.16) needed by python3-hdmf-2.4.0-1.fc34.noarch

Numpy is now at 1.20 h5py is at 3.1.0

I've also run into a few issues with python packages when updating them---I guess we need to remember to check updates locally before pushing them.

BZ#1868037 python-hdmf-2.4.0 is available

Same here:

Problem: cannot install the best update candidate for package OpenImageIO-2.2.10.0-1.fc33.x86_64
  - nothing provides libopenvdb.so.8.0()(64bit) needed by OpenImageIO-2.2.11.1-1.fc33.x86_64
BZ#1926607 OpeImageIO needs rebuild for openvdb 8.0.1
karma

Same here:

Problem: package libabigail-fedora-1.7-2.fc33.x86_64 requires libabigail(x86-64) = 1.7-2.fc33, but none of the providers can be installed
  - cannot install both libabigail-1.8-1.fc33.x86_64 and libabigail-1.7-2.fc33.x86_64
  - cannot install both libabigail-1.7-2.fc33.x86_64 and libabigail-1.8-1.fc33.x86_64
  - cannot install the best update candidate for package libabigail-fedora-1.7-2.fc33.x86_64
  - cannot install the best update candidate for package libabigail-1.7-2.fc33.x86_64

Very odd. This isn't working for me at all here:

$ rpm -q podman containers-common
podman-2.2.0-2.fc33.x86_64
containers-common-1.2.0-10.fc33.x86_64

$ podman run -it fedora:33 /bin/bash
Error: container_linux.go:349: starting container process caused "error adding seccomp rule for syscall socket: permission denied": OCI permission denied

Downgrading packages fixes it:

$ rpm -q podman containers-common
podman-2.1.1-12.fc33.x86_64
containers-common-1.2.0-3.fc33.x86_64

$ podman run -it fedora:33 /bin/bash
[root@48ef5add7d53 /]# exit

cldr-emoji-annotation-38~beta-3.fc33 updates correctly, thanks. (Fetched it from koji)

Also seeing this issue, even with --allowerasing:

 sudo dnf update --allowerasing --best
Last metadata expiration check: 0:10:07 ago on Mon 28 Sep 2020 09:52:37 BST.
Error: 
 Problem 1: cannot install the best update candidate for package cldr-emoji-annotation-dtd-38.0_13.0_0_1~alpha1-1.fc33.noarch
  - problem with installed package cldr-emoji-annotation-dtd-38.0_13.0_0_1~alpha1-1.fc33.noarch
  - nothing provides cldr-emoji-annotation = 38~beta-2.fc33 needed by cldr-emoji-annotation-dtd-1:38~beta-2.fc33.noarch
 Problem 2: cannot install the best update candidate for package cldr-emoji-annotation-38.0_13.0_0_1~alpha1-1.fc33.noarch
  - problem with installed package cldr-emoji-annotation-38.0_13.0_0_1~alpha1-1.fc33.noarch
  - package cldr-emoji-annotation-dtd-38.0_13.0_0_1~alpha1-1.fc33.noarch requires cldr-emoji-annotation = 38.0_13.0_0_1~alpha1-1.fc33, but none of the providers can be installed
  - package cldr-emoji-annotation-1:38~beta-2.fc33.noarch requires cldr-emoji-annotation-dtd, but none of the providers can be installed
  - cannot install both cldr-emoji-annotation-1:38~beta-2.fc33.noarch and cldr-emoji-annotation-38.0_13.0_0_1~alpha1-1.fc33.noarch
  - cannot install the best update candidate for package cldr-emoji-annotation-dtd-38.0_13.0_0_1~alpha1-1.fc33.noarch
  - nothing provides cldr-emoji-annotation = 38~beta-2.fc33 needed by cldr-emoji-annotation-dtd-1:38~beta-2.fc33.noarch
(try to add '--skip-broken' to skip uninstallable packages)

Seems to work well too, not noticed any regressions yet.

Just ran a system-upgrade, and did not see the FTI bug anymore. Thanks very much!

BZ#1852141 F33FailsToInstall: python3-google-api-client

Works find in normal usage, no regressions noted. Thanks!

I've "revoked" it. Not sure what that means, but it seems to stop the update from going to stable hopefully.

This makes python-pynwb uninstallable on Fedora 32. It should not be pushed to stable until a version of pywnb that can use this new version is available:

$ sudo dnf update --exclude=podman*
[sudo] password for asinha: 
Last metadata expiration check: 1:06:02 ago on Mon 17 Aug 2020 15:50:28 BST.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package python3-pynwb-1.2.1-1.fc32.noarch
  - nothing provides (python3.8dist(hdmf) >= 1.6.4 with python3.8dist(hdmf) < 2) needed by python3-pynwb-1.3.3-1.fc32.noarch
 Problem 2: problem with installed package python3-pynwb-1.2.1-1.fc32.noarch
  - package python3-pynwb-1.2.1-1.fc32.noarch requires (python3.8dist(hdmf) >= 1.5.4 with python3.8dist(hdmf) < 2), but none of the providers can be installed
  - cannot install both python3-hdmf-2.0.1-1.fc32.noarch and python3-hdmf-1.6.2-1.fc32.noarch
  - cannot install both python3-hdmf-1.6.2-1.fc32.noarch and python3-hdmf-2.0.1-1.fc32.noarch
  - cannot install both python3-hdmf-1.6.1-1.fc32.noarch and python3-hdmf-2.0.1-1.fc32.noarch
  - cannot install the best update candidate for package python3-hdmf-1.6.2-1.fc32.noarch
  - nothing provides (python3.8dist(hdmf) >= 1.6.4 with python3.8dist(hdmf) < 2) needed by python3-pynwb-1.3.3-1.fc32.noarch
============================================================================================================================================================================================================================================== Package                                                    Architecture                                        Version                                                    Repository                                                    Size
==============================================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 python3-hdmf                                               noarch                                              1.6.1-1.fc32                                               fedora                                                       207 k
 python3-hdmf                                               noarch                                              2.0.1-1.fc32                                               updates-testing                                              226 k
Skipping packages with broken dependencies:
 python3-pynwb                                              noarch                                              1.3.3-1.fc32                                               updates-testing                                              126 k

Transaction Summary
==============================================================================================================================================================================================================================================Skip  3 Packages

Nothing to do.
Complete!

BZ#1849403 dav1d-0.7.1 is available
BZ#1849403 dav1d-0.7.1 is available