Comments

30 Comments

#2018674 - 👍

ABI change is limited to a Qt5Widgets private APIs: QWidgetTextControl, QTextEditControl, QPlainTextEditControl, which nothing seems to be using directly according to github search.

See also: https://invent.kde.org/qt/qt/qtbase/-/merge_requests/74

1 Removed function symbol not referenced by debug info:
  [D] _ZN18QWidgetTextControl13setTextCursorERK11QTextCursor@@Qt_5.15.2_PRIVATE_API
1 Added function symbol not referenced by debug info:
  [A] _ZN18QWidgetTextControl13setTextCursorERK11QTextCursorb@@Qt_5.15.2_PRIVATE_API
karma

Works fine, as far as my testing goes. Thanks for the quick fix!

karma

Breaks fedpkg mockbuild --enablerepo updates-testing.

ERROR: Command failed:
 # /usr/bin/dnf --installroot /var/lib/mock/fedora-35-x86_64-bootstrap/root/ --releasever 35 ('--enablerepo', 'updates-testing') --setopt=deltarpm=False --allowerasing --disableplugin=local --disableplugin=spacewalk --disableplugin=versionlock install dnf dnf-plugins-core --setopt=tsflags=nocontexts
No matches found for the following disable plugin patterns: local, spacewalk
No such command: ('--enablerepo', 'updates-testing'). Please use /usr/bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(('--enablerepo', 'updates-testing'))'"

Same error if you run mock ... --enablerepo x directly.

random set of Qt apps 👍 #2018674 👍

Thank you, Rex!

 Problem: package python3-jwt+crypto-2.1.0-2.fc35.noarch requires (python3.10dist(cryptography) < 4 with python3.10dist(cryptography) >= 3.3.1), but none of the providers can be installed
  - cannot install both python3-cryptography-35.0.0-2.fc35.x86_64 and python3-cryptography-3.4.7-5.fc35.x86_64
  - cannot install the best update candidate for package python3-jwt+crypto-2.1.0-2.fc35.noarch
  - cannot install the best update candidate for package python3-cryptography-3.4.7-5.fc35.x86_64

Confirmed working on ppc64le; lua panic is fixed.

BZ#1983288 neovim crash on aarch64
BZ#1983812 swaybg-1.1 is available
BZ#1978887 neovim-0.5.0 is available

Almost working, but a few unwanted newlines slipped in. Notably, the line break after DESTDIR makes it so that DESTDIR is not applied to a command in the next line.

% rpm -E '%zig_install'

    DESTDIR="/home/alebastr/rpmbuild/BUILDROOT/%{NAME}-%{VERSION}-%{RELEASE}.x86_64"
    /usr/bin/zig \
        build \
        --verbose  \
        --cache-dir zig-cache \
        install \
        --prefix "/usr" \
        --prefix-lib-dir "/usr/lib64" \
        --prefix-exe-dir "/usr/bin" \
        --prefix-include-dir "/usr/include"

Overall, it's not a good practice to start macro with a newline; for example, xvfb-run %zig_test will not do what any experienced packager expects it to do.

License     : MIT

That should be LGPLv3+ and MIT. Upstream changed the license as they use fragments of GTK code.

Thanks for your work on packaging alacritty!

BZ#1889026 slurp-1.3.0 is available